KNOWLEDGE BASE

Error "Unable to complete offline activation" or Re-Prompt for Activation on Tableau Desktop After Processing Activation.tlf File


Published: 13 Jul 2016
Last Modified Date: 09 Dec 2022

Issue

When attempting to process the activation.tlf file for an offline activation of Tableau Desktop, the following error may occur:

Unable to complete offline activation
 
In addition, sometimes when double-clicking the activation.tlf file, no error displays but when opening Tableau Desktop, you are prompted to activate again.

Environment

  • Tableau Desktop

Resolution

Try one of the following solutions:
  • Ensure that you are processing the activation.tlf file only on the computer or virtual machine which created the offline.tlq. The activation.tlf file is specific to the computer that created the offline.tlq and cannot be reused on other computers. 
  • Attempt double-clicking the activation.tlf file with elevated (administrator) permissions. 
  • Verify the Flexnet license service is running. For more information, see Troubleshoot Your Tableau Desktop or Tableau Prep Builder Installation
  • If on Mac OS, review this article for more macOS specific options.
If the above initial information does not assist, please contact Tableau Technical Support and provide the following:

Cause

  • The Tableau Desktop activation file must be run on the same computer where the offline.tlq file was created.
  • Permissions may not be sufficient to store license data and license cache.
  • The Flexnet license service may not be in the correct state.
  • The location where license data is stored may be corrupt.

Additional Information




 
Did this article resolve the issue?