BASE DE CONOCIMIENTO

Error "Could not start Hyper: Failed to start a new Hyper instance" al abrir libros de trabajos de Tableau


Publicado: 07 Oct 2021
Fecha de la última modificación: 06 Mar 2024

Problema

Al abrir libros de trabajo de Tableau en Tableau Desktop, es posible que se produzca el siguiente error:

Could not start Hyper: Failed to start a new Hyper instance. Context: 0x86a93465 Caused by: The Hyper server process exited during startup with exit code: 1 <...> (No se pudo iniciar Hyper: error al iniciar una nueva instancia de Hyper. El proceso del servidor Hyper se cerró durante el inicio con el código de salida: 1)
stderr: Unable to open log file: CreateFileW<...> (No es posible abrir un archivo de registro: CreateFileW)
The tag present in the reparse point buffer is invalid FileListener in error state after initial rotate() Context: 0x13cead20 (La etiqueta presente en el búfer de punto de reprocesamiento no es válida. FileListener en estado de error después de la rotación inicial() Contexto: 0x13cead20)
Unable to connect to the Tableau Data Extract server'' (No es posible conectarse con el servidor de extracción de datos de Tableau). Check that the server is running and that you have access privileges to the requested database   

O bien 

An error occurred while communicating with Tableau Data Extract.
Conexión incorrecta: Tableau no ha podido conectarse a la fuente de datos.
Error Code: AC0843EA
Could not start Hyper: Failed to start a new Hyper instance.
Context: 0x86a93465
(Se produjo un error al comunicarse con Extracción de datos de Tableau. Conexión incorrecta: Tableau no ha podido conectarse a la fuente de datos. Código de error: AC0843EA. No se pudo iniciar Hyper: error al iniciar una nueva instancia de Hyper. Contexto: 0x86a93465).

Entorno

  • Tableau Desktop
  • OneDrive

Solución

Este problema puede suceder tanto en Windows como en Mac si se utiliza OneDrive y la carpeta del repositorio de Tableau está incluida en las carpetas de sincronización con OneDrive, lo cual impide que Tableau escriba los registros de Hyper y origina el error. 

Use una de las siguientes opciones:

Opción 1

  1. Cree una nueva carpeta, que no esté sincronizada con OneDrive.
  2. En Tableau Desktop, seleccione Archivo > Ubicación de repositorio.
  3. Seleccione la nueva carpeta que funcionará como la nueva ubicación del repositorio en el cuadro de diálogo ''Seleccionar un repositorio''.
  4. Reinicie Tableau Desktop para que utilice el nuevo repositorio. 

Opción 2

Anule la selección de la carpeta del repositorio de Tableau Desktop (la ubicación predeterminada es Documents/My Tableau Repository) en la aplicación de OneDrive para sincronización. Si quiere obtener más información para realizar estos pasos, consulte Elegir qué carpetas de OneDrive se sincronizarán con su equipo.

Opción 3

Es posible que reciba este error relacionado con el tipo de CPU que se utiliza. Para obtener más detalles, consulte el siguiente artículo. 

Error "Could Not Start Hyper: Failed To Start A New Hyper Instance" (No se ha podido iniciar Hyper: Error al iniciar una nueva instancia de Hyper) después de instalar Tableau 2020.4 o una versión posterior

Causa

La sincronización de OneDrive impide que Tableau escriba los registros hyperd.
¿Fue de ayuda este artículo para resolver el problema?