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Scheduled Extract Refresh Intermittently Fails Without Error Message


Published: 21 Oct 2016
Last Modified Date: 20 Jul 2023

Issue

When published extracts are scheduled to refresh frequently throughout the day, some extracts are not updating as frequently as expected.
Additionally, the message "[datasource name extract refresh] is already queued. Not queuing a duplicate" appears in the backgrounder log many times.

Environment

Tableau Server 

Resolution

One of the following options may resolve the issue: 
Option 1
If it is important to keep data as fresh as possible, consider making a Live Connection to the database to prevent constant extract refreshes.
Option 2
Using the Background Tasks for Extract report in Tableau Server, identify extacts that take longer then the Refresh Window to process. If an extract takes 20 minutes to complete, having it refresh every 15 minutes will cause a backgrounder to become monopolized by that single extract refresh.
Option 3
Decrease the frequency of the extract refreshes. If the extracts are all being refreshed in 15-minute increments, increase to 30-minute schedules
Option 4
Reconfigure Tableau Server processes to increase the backgrounder count

Note: If there are no available system resources, increasing the backgrounder process count will not resolve the issue.


 

Cause

The Backgrounder is overloaded and cannot complete the jobs in the time available.

Additional Information

  • Search the Backgrounder log folder for the phrase "Storing to repository" to find instances of successful extract refreshes
  • Search the Backgrounder log folder for the phrase "already queued. Not queuing a duplicate" to find instances of extract refreshes being triggered when already running
  • There are no error messages presented in the Background Tasks for Extracts report.

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