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Error "Worksheet Unavailable. There was a problem connecting to "<Data Source Name>" data source." After Opening a Workbook


Published: 27 Sep 2016
Last Modified Date: 09 Dec 2022

Issue

When opening a workbook in Tableau Desktop with a published data source, the following error might occur:
"Worksheet Unavailable, There was a problem connecting to "<Data Source Name>" data source."
 

Environment

  • Tableau Desktop
  • Tableau Server
  • Proxy and Firewall

Resolution

  1. If Tableau Server is behind a proxy, ensure that the 'gateway.public.host name' is set correctly. For more information, see: Configuring Proxies for Tableau Server
  2. If the above information is correct, and the issue continues, try the following:
    • Publishing the data source again.
    • Right click on Data Sources > Tableau Data Server > Edit server and site path > Enter the expected Tableau Server site name.
    • If there are many data sources affected by this issue, using REST API to write scripts may allow automation of the above process. See Update Data Source Connection for more information. 

      The Developer Portal in the Community is the best resource for assistance in writing REST API scripts.

Cause

This error might occur for the following reasons: 
  1. The " gateway.public. host name " was not updated when Tableau Server was upgraded. 
  2. Proxies have been known to cause issues where a Tableau Server address will point back to localhost, or the Tableau Server machine name, rather than the site name.
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