KNOWLEDGE BASE

Error "Unable to connect to the file "<file path>". Check that the file exists and that you have sufficient access privileges for it." Refreshing Extract


Pubblicato: 14 May 2015
Data dell'ultima modifica: 20 Oct 2022

Problema

Durante l'aggiornamento di un'estrazione di un file Excel che si trova su un'unità di rete, l'estrazione potrebbe avere esito negativo e il seguente errore viene visualizzato nella vista Attività in background:

com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the file "<file name>".Check that the file exists and that you have sufficient access privileges for it. (Impossibile connettersi al file "<nome file>". Controlla che il file esista e di avere i privilegi di accesso necessari per il file.)

Ambiente

  • Tableau Server
  • Excel

Soluzione

  • Verifica che il file si trovi ancora nella posizione prevista.
  • Aggiorna la connessione dati in Tableau Desktop per riflettere il percorso UNC alla cartella di lavoro Excel, anziché un percorso file che include una lettera di unità mappata, e ripubblica la cartella di lavoro.
  • Assicurati che l'utente Esegui come di Tableau Server possa accedere alla posizione in cui il file è archiviato. 
Per verificare se l'utente Esegui come di Tableau Server ha accesso alla posizione del file, accedi al computer sul quale è in esecuzione Tableau Server come utente "Esegui come" e prova ad accedere alla cartella dove è situato il file, utilizzando il percorso UNC in una finestra di Esplora file di Windows.

 

Causa

Il file è stato spostato o eliminato, oppure l'utente Esegui come di Tableau Server non ha accesso alla posizione in cui il file è memorizzato. Ciò può dipendere dal fatto che il percorso utilizzato per connettersi all'origine dati è un percorso mappato. Poiché l'account utente Esegui come non può accedere a risorse che sono state autenticate nel contesto di sicurezza di un altro utente, non può utilizzare il percorso mappato.


 
Con questo articolo hai risolto il problema?