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Error "Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it." Refreshing Extract


Published: 14 May 2015
Last Modified Date: 24 Aug 2022

Issue

When refreshing an extract of an Excel file that is located on a network drive, the extract might fail and the following error appears in the Background Task view:

com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it.

Environment

  • Tableau Server
  • Excel

Resolution

  • Check to ensure that the file is still in the expected location.
  • Update the data connection(s) in Tableau Desktop to reflect the UNC path to the Excel workbook, instead of a file path that includes a mapped drive letter, and republish the workbook.
  • Ensure that the Tableau Server run as user has access to the location where the file is being stored. 
To test whether the Tableau Server run as user has access to the file location, log in to the computer running Tableau Server as the 'Run As' user and attempt to access the folder where the file is stored, using the UNC path in a Windows File Explorer window.

 

Cause

The file has been moved or deleted, or the Tableau Server Run As user does not have access to the location where the file is stored. This can be because the path used to connect to the data source is a mapped path.  Because the Run As user account cannot access resources that have been authenticated in the security context of another user, it cannot use the mapped path.


 
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