KNOWLEDGE BASE

Explorer (Can Publish) Unable to Publish to a Site When User Visibility is Set to Limited


Published: 09 Apr 2020
Last Modified Date: 12 Apr 2023

Issue

When the user visibility setting on a Tableau Server or Tableau Cloud site is set to "Limited" users with the Explorer (can publish) role will be unable to publish and will encounter errors such as the following:

You do not have permission to publish to any projects.
Contact your Tableau Server administrator for access.


User does not have permission to add tags on content VIEW with ids. (errorCode=1)

Environment

 
  • Tableau Server 2019.4 and newer
  • Tableau Cloud
  • Tableau Desktop

Resolution

Tableau Cloud is updated as of 2023.1.
Upgrade to Tableau Server 2023.1 or newer.

If Tableau Server is at a lower maintenance level, please review these workarounds:

Option 1
Change the User Visibility site setting to "Full." For more information, see Manage Site User Visibility.
Option 2
Upgrade the affected user's site role to Creator (or higher). For more information, see Set Users' Site Roles.

Cause

An update to both Tableau Server and Tableau Cloud for Web Authoring has allowed this functionality.
Did this article resolve the issue?