BASE DE CONOCIMIENTO

La reindexación del servidor de búsqueda no resolvió los problemas de visualización de proyectos, libros de trabajo o vistas


Publicado: 16 Mar 2020
Fecha de la última modificación: 03 Apr 2023

Problema

Los proyectos, los libros de trabajo o las vistas no se pueden ver en la interfaz de usuario de Tableau Server, incluso después de ejecutar un comando tsm maintenance reindex-search

Después de intentar reindexar el registro de búsqueda, se pueden mostrar líneas similares a las siguientes.

Registros de tabadmincontroller

INFO com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Progress update for job RebuildSearchIndex, id: 806, step: RunIndexingOnVizportal, status: Running, message key: job.rebuild_search_index.step.run_indexing_on_vizportal, message data: ,
2020-03-12 20:02:42.494 -0500 pool-14-thread-1 : ERROR com.tableausoftware.tabadmin.webapp.init.RebuildSearchIndex - Failed to rebuild search index. Please check whether a valid Tableau Server license is present and check the vizportal logs.

Registros de VizPortal
2020-03-12 20:02:42.492 -0500 (,,,,) VizportalMaintenanceServiceThread : ERROR com.tableausoftware.domain.solr.SearchService - Failed to gather solr stats
com.tableausoftware.domain.exceptions.SearchServiceException: Error from server at https://localhost:8191/solr/view: Expected mime type application/octet-stream but got application/json. {
"error":{
"metadata":[
"error-class","org.apache.solr.core.SolrCoreInitializationException",
"root-error-class","org.apache.lucene.index.CorruptIndexException"],
"msg":"SolrCore 'view' is not available due to init failure: Error opening new searcher",
"trace":"org.apache.solr.core.SolrCoreInitializationException: SolrCore 'view' is not available due to init failure: Error opening new searcher\r\n\tat

 

Entorno

  • Tableau Server

Solución

  1. Asegúrese de que Tableau Server tenga la licencia esperada. Vaya a la línea de comandos o la interfaz de usuario de TSM y verifique que las licencias se hayan activado de la forma esperada.   Si las licencias no se activaron de la forma esperada, vuelva a añadir las licencias o póngase en contacto con el Soporte técnico antes de continuar con los pasos siguientes.
  2. Ejecute tsm stop
  3. Cuando Tableau Server se detenga por completo, se recomienda realizar una copia de seguridad. Si bien no es esperable que ninguna acción aquí genere problemas para el sistema, siempre es una práctica recomendada comprobar que exista una copia de seguridad actual.  
  4. Restablezca Searchserver mediante la ejecución de: tsm maintenance reset-searchserver.
  5. Una vez finalizado el comando, se debe reactivar el servidor con tsm start.

    • Si los pasos anteriores no resuelven el problema, póngase en contacto con el Soporte técnico de Tableau.

    Causa

    Este problema parece suceder por un daño en el índice del servidor de búsqueda subyacente. Esto se puede producir durante un reinicio inesperado, después de actualizaciones del sistema, etc. El comando tsm maintenance reset-searchserver descarta el índice antiguo y lo reconstruye por completo. 
    ¿Fue de ayuda este artículo para resolver el problema?