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Re-indexing Search Server Did Not Resolve Issues with Viewing Projects, Workbooks, and/or Views


Published: 16 Mar 2020
Last Modified Date: 07 Mar 2023

Issue

Projects, Workbooks, and/or Views are not visible in the Tableau Server UI, even after running a tsm maintenance reindex-search command

After attempting to reindex the search log lines similar to the below may appear:

Tabadmincontroller Logs

INFO com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Progress update for job RebuildSearchIndex, id: 806, step: RunIndexingOnVizportal, status: Running, message key: job.rebuild_search_index.step.run_indexing_on_vizportal, message data: ,
2020-03-12 20:02:42.494 -0500 pool-14-thread-1 : ERROR com.tableausoftware.tabadmin.webapp.init.RebuildSearchIndex - Failed to rebuild search index. Please check whether a valid Tableau Server license is present and check the vizportal logs.

VizPortal Logs
2020-03-12 20:02:42.492 -0500 (,,,,) VizportalMaintenanceServiceThread : ERROR com.tableausoftware.domain.solr.SearchService - Failed to gather solr stats
com.tableausoftware.domain.exceptions.SearchServiceException: Error from server at https://localhost:8191/solr/view: Expected mime type application/octet-stream but got application/json. {
"error":{
"metadata":[
"error-class","org.apache.solr.core.SolrCoreInitializationException",
"root-error-class","org.apache.lucene.index.CorruptIndexException"],
"msg":"SolrCore 'view' is not available due to init failure: Error opening new searcher",
"trace":"org.apache.solr.core.SolrCoreInitializationException: SolrCore 'view' is not available due to init failure: Error opening new searcher\r\n\tat

 

Environment

  • Tableau Server

Resolution

  1. Ensure Tableau Server is licensed as expected. Go to TSM either the UI or the command line, and verify the licenses are activated as expected.   If licenses are not activated as expected, add the licenses back or contact Technical Support before continuing with the next steps.
  2. Run tsm stop
  3. Once Tableau Server is fully stopped, you may wish to take a backup. While we don't expect anything we do here to cause issues for the system, it is always best practice to ensure there is a current backup.  
  4. Reset the Searchserver by running: tsm maintenance reset-searchserver.
  5. After that command finishes, we'll want to bring the server back up with tsm start.

    • If the above steps does not resolve the issue, contact Tableau Technical Support.

    Cause

    This issue appears to occur because of a corruption to the underlying searchserver index. This can occur during an unexpected reboot, after system upgrades, etc. The tsm maintenance reset-searchserver command gets rid of the old index and completely rebuilds it. 
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