BASE DE CONOCIMIENTO

Error "Connectionless Failure (Status code = 10000)" y "Kerberos RunAs authentication is not enabled on Linux" al actualizar datos en la nube


Publicado: 03 May 2019
Fecha de la última modificación: 19 Jun 2023

Problema

Al usar Tableau Cloud para actualizar una fuente de datos o un libro de trabajo publicados, se produce un error como el siguiente: 

Connectionless Failure (status code = 10000) (Error sin conexión [código de estado = 10000])
There was an unknown connection error to the database.
(Se ha producido un error de conexión desconocido en la base de datos).
Kerberos RunAs authentication is not enabled on Linux. (La autenticación Kerberos RunAs no se habilitó en Linux).
 

Entorno

  • Tableau Cloud
  • Fuente de datos local

Solución

  • Si sus datos están alojados de manera local o en la nube privada, use Tableau Bridge. Tableau Bridge es una aplicación gratuita e independiente que se instala en un equipo con acceso a los datos. Bridge ejecutará la actualización localmente y luego enviará la nueva extracción a Tableau Cloud.

Nota: Tableau Bridge solo puede usarse con fuentes de datos publicadas de forma individual y no con fuentes de datos integradas en un libro de trabajo. Para actualizar las fuentes de datos con Bridge, vuelva a publicar el libro de trabajo con las fuentes de datos publicadas de forma independiente. Para obtener más información, consulte Configurar un programa de actualización de Bridge.

Si desea ver las respuestas a preguntas frecuentes sobre Tableau Bridge, consulte Preguntas frecuentes de Tableau Bridge.

2. Cuando se conecte a la fuente de datos y la publique, utilice el nombre de usuario y la contraseña, no la autenticación de Windows. Debido a que Tableau Cloud no tiene acceso a su red ni a Active Directory, no puede identificarse con la autenticación de Windows y, en su lugar, debe usar un nombre de usuario y una contraseña.

Causa

Tableau Cloud no puede acceder a la fuente de datos alojada de manera local o mediante la autenticación de Windows.  A menudo, esto puede ocurrir si el programa de actualización de la extracción no se configuró correctamente.
 
 
¿Fue de ayuda este artículo para resolver el problema?