KNOWLEDGE BASE

Error "Connectionless Failure (Status code = 10000)" and "Kerberos RunAs authentication is not enabled on Linux" Refreshing Data on Cloud


Published: 03 May 2019
Last Modified Date: 13 Apr 2023

Issue

When refreshing a published data source or workbook using Tableau Cloud, an errors display such as: 

Connectionless Failure (status code = 10000)
There was an unknown connection error to the database.

Kerberos RunAs authentication is not enabled on Linux.
 

Environment

  • Tableau Cloud
  • On-premises data source

Resolution

  • If your data is hosted on-premises or in the private cloud, use Tableau Bridge. Tableau Bridge is a separate, free application that you install on a computer that has access to your data. Bridge will run the refresh locally and then push the new extract up to Tableau Cloud.

Note: Tableau Bridge can only be used against individually published data sources, and it can't be used against data sources embedded in a workbook. To refresh data sources using Bridge, republish the workbook with data sources published separately. For more information, see Set Up a Bridge Refresh Schedule.

For answers to commonly asked questions about Tableau Bridge, see Tableau Bridge FAQ.

  • If your data is hosted in the publicly-accessible cloud: the solution has two parts:

    1. Ensure that you have whitelisted the appropriate Tableau Cloud IP addresses, as discussed in Tableau Cloud IP addresses for data provider authorization. This allows Tableau Cloud to reach the database.
2. When you connect to the data source and publish it, use username/password authentication, not Windows Authentication. Because Tableau Cloud doesn't have access to your network or Active Directory, it cannot authenticate with Windows Authentication, and must instead use username/password.

Cause

Tableau Cloud cannot access the data source hosted on-premises or using Windows Authentication.  This can often occur if the extract refresh schedule was not setup correctly.
 
 
Did this article resolve the issue?