KNOWLEDGE BASE

Tableau Server su Windows Server 2016 non risponde o diventa senza licenza


Pubblicato: 18 Dec 2018
Data dell'ultima modifica: 28 Dec 2023

Problema

Tableau Server su Windows Server 2016 presenta vari problemi, tra cui: 

  • Processi pianificati lenti o non riusciti 
  • Tableau Server diventa danneggiato 
  • Tableau Server diventa senza licenza 
  • Il rendering delle visualizzazioni viene eseguito più lentamente 

Inoltre, i log di ClusterController e/o Selezione background possono contenere il seguente errore:
"Caused by: java.io.IOException: Unable to establish loopback connection" (Causato da: java.io.IOException: Impossibile stabilire una connessione di loopback)

Ambiente

  • Tableau Server
  • Windows Server 2016
  • Windows Firewall 
  • Connessioni live alle origini dati

Soluzione

Imposta Tableau Server Resource Manager (SRM) per eseguire il polling con una frequenza inferiore: ogni 10 secondi anziché in base al valore predefinito (1). 
Nota: Questa soluzione richiede il riavvio di Tableau Server. 

Per Tableau Server 2018.2 e versioni successive:

Apri un prompt dei comandi come amministratore nel nodo in cui è installato TSM e immetti i seguenti comandi:

tsm configuration set -k native_api.check_interval_seconds -v 10 --force-keys
tsm pending-changes apply

 
 

Causa

In base a determinate caratteristiche di caricamento (ad esempio, il caricamento di cartelle di lavoro con molte connessioni live), un nodo di Tableau Server può avere numerosi processi che inviano e restano in ascolto dei messaggi broadcast di Tableau Server Resource Manager (SRM). Nelle future release di Tableau Server, per impostazione predefinita il polling SRM sarà configurato con una frequenza inferiore. Questa modifica è tracciata tramite il problema con ID 817676.  

Il difetto 817676 è stato corretto nelle versioni di manutenzione di marzo 2019.
https://www.tableau.com/it-it/support/releases/server/2019.1.2
https://www.tableau.com/it-it/support/releases/server/2018.3.5
https://www.tableau.com/it-it/support/releases/server/2018.2.8
https://www.tableau.com/it-it/support/releases/server/2018.1.11
https://www.tableau.com/it-it/support/releases/server/10.5.14
https://www.tableau.com/it-it/support/releases/server/10.4.15
https://www.tableau.com/it-it/support/releases/server/10.3.19
 

Ulteriori informazioni

Questa soluzione è attualmente consigliata per tutte le installazioni di Tableau Server in esecuzione su Windows Server 2016. 
Se desideri verificare se il problema che stai riscontrando corrisponde alle indicazioni fornite in questo articolo, controlla quanto segue. 
Controlla che il servizio Windows Firewall sia in esecuzione: 
  1. Fai clic su Start, quindi digita "services.msc"
  2. scorri fino a "Windows Firewall"
  3. controlla che lo stato sia "In esecuzione"
Controlla se è presente l'errore "Impossibile stabilire una connessione di loopback" nei log di Tableau Server. 
Controlla che i registri eventi di Windows non contengano l'ID evento 4227 o 4231. Questi ID evento indicano l'esaurimento della porta temporanea. Se si verificano problemi di esaurimento delle porte, consulta Problemi di esaurimento delle porte di Tableau Server.

 
Con questo articolo hai risolto il problema?