BASE DE CONOCIMIENTO

Tableau Server en Windows Server 2016 no responde o no tiene licencia


Publicado: 18 Dec 2018
Fecha de la última modificación: 28 Dec 2023

Problema

Tableau Server en Windows Server 2016 muestra varios problemas, entre los que se incluyen: 

  • Trabajos programados lentos o erróneos
  • Tableau Server usa una versión antigua 
  • Tableau Server pierde su licencia 
  • Las visualizaciones se renderizan más despacio 

Además, los registros del controlador del clúster o del procesador en segundo plano pueden mostrar el siguiente error:
"Caused by: java.io.IOException: Unable to establish loopback connection" (Error causado por java.io.IOException: Error al establecer la conexión en bucle"

Entorno

  • Tableau Server
  • Windows Server 2016
  • Windows Firewall 
  • Conexiones en tiempo real con fuentes de datos

Solución

Configure el administrador de recursos de Tableau Server (SRM) para que realice consultas menos frecuentes (cada 10 segundos en lugar de cada segundo). 
Nota: esta solución requiere que reinicie Tableau Server. 

Para Tableau Server 2018.2 y versiones posteriores:

Abra el símbolo del sistema como administrador en el nodo donde está instalado TSM y escriba estos comandos:

tsm configuration set -k native_api.check_interval_seconds -v 10 --force-keys
tsm pending-changes apply

 
 

Causa

Según algunas características de carga (cargar libros de trabajo con varias conexiones en tiempo real, por ejemplo), un nodo de Tableau Server podría tener varios procesos publicando y atendiendo los mensajes retransmitidos desde el administrador de recursos de Tableau Server (SRM). Las próximams versiones de Tableau Server harán que el SRM realice consultas con menos frecuencia que la establecida de forma predeterminada. Este cambio se encuentra bajo seguimiento, con la ID de problema 817676.  

El error 817676 se ha solucionado en las versiones de mantenimiento de marzo de 2019.
https://www.tableau.com/es-es/support/releases/server/2019.1.2
https://www.tableau.com/es-es/support/releases/server/2018.3.5
https://www.tableau.com/es-es/support/releases/server/2018.2.8
https://www.tableau.com/es-es/support/releases/server/2018.1.11
https://www.tableau.com/es-es/support/releases/server/10.5.14
https://www.tableau.com/es-es/support/releases/server/10.4.15
https://www.tableau.com/es-es/support/releases/server/10.3.19
 

Información adicional

Esta solución se recomienda actualmente para todas las instalaciones de Tableau Server en Windows Server 2016. 
Si quiere comprobar que el problema coincide con lo indicado en este artículo, consulte lo siguiente.
Compruebe que Windows Firewall funciona: 
  1. Haga clic en Inicio y escriba “services.msc”
  2. Vaya hasta “Windows Firewall”
  3. Compruebe que el estado es “En ejecución”
Busque "Unable to establish loopback connection" en los registros de Tableau Server. 
Compruebe que los registros de eventos de Windows no contienen las ID de evento 4227 ni 4231. Estas ID indican que los puertos están exhaustos. Si tiene este tipo de problema, consulte Puertos exhaustos en Tableau Server.

 
¿Fue de ayuda este artículo para resolver el problema?