Error 0x80070643: Failed to execute MSI package" al instalar o desinstalar la versión 2022.1 del agente RMT en nodos de Tableau Server
Publicado: 14 Apr 2022 Fecha de la última modificación: 30 Jun 2022
Problema
Al instalar, actualizar o desinstalar la versión 2022.1 de Tableau RMT Agent en los nodos de Tableau Server, aparece el siguiente mensaje de error:
En los registros de este error de instalación, aparecen los siguientes errores:
[2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to uninstall MSI package. (No se pudo desinstalar el paquete MSI) [2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package. (No se pudo ejecutar el paquete MSI) [20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to configure per-machine MSI package. (No se pudo configurar el paquete MSI por equipo) [20E8:0D58][2022-04-12T21:08:50]i319: Applied execute package: SERVER, result: 0x80070643, restart: None (Se aplicó el paquete de ejecución: SERVER; resultado: 0x80070643; reiniciar: ninguno) [20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package. (No se pudo ejecutar el paquete MSI) Cuando el usuario aplica la solución alternativa que encuentra en la siguiente documentación, el problema no se resuelve. La solución alternativa que se describe en la documentación debajo es actualizar la política de GPO, aunque no se resuelve el problema: Fatal error while installing RMT tool (Error fatal al instalar la herramienta RMT)
Una solución alternativa de este problema es usar el solucionador de problemas de Microsoft Windows para desinstalar por completo Tableau RMT Agent y, luego, volver a instalarlo en el equipo. Los siguientes pasos pueden facilitar el proceso:
1. Descargue el solucionador de problemas de Microsoft Windows:
2. Ejecute el programa descargado, "MicrosoftProgram_Install_and_Uninstall.meta.diagcab", en el equipo afectado. Haga clic en "Siguiente" para continuar.
3. El programa detectará posibles problemas y ofrecerá opciones para solucionar problemas con las instalaciones o desinstalaciones. Seleccione "Desinstalar".
4. En la lista proporcionada, busque el programa Tableau Resource Monitoring Tool. Selecciónelo y haga clic en Siguiente.
5. El solucionador de problemas terminará de ejecutarse y permitirá desinstalar el programa de Windows en Agregar o quitar programas.
6. Desinstale la instancia de Tableau Resource Monitoring Tool.
7. Una vez que RMT está desinstalado, puede volver a ejecutar el instalador. De este modo, RMT Agent podrá instalarse correctamente.
Causa
El equipo de desarrollo se está ocupando de este problema.
Gracias por brindarnos sus comentarios sobre la eficacia de este artículo.