BASE DE CONOCIMIENTO

No hay opciones para activar con una clave de producto en Tableau Desktop


Publicado: 05 Apr 2022
Fecha de la última modificación: 11 Oct 2023

Problema

Al activar Tableau Desktop, los usuarios no ven una opción para activar con una clave de producto. Solo una opción (Activar iniciando sesión en un servidor) está disponible.

Entorno

  • Tableau Desktop
  • Windows
  • Mac

Solución

Consulte con el administrador de Tableau Server o el equipo de TI de la empresa para asegurarse de que LBLM NO sea el método de activación deseado en el entorno de Tableau. La configuración predeterminada es mostrar tanto las opciones de activación LBLM como la clave de producto en Tableau.  Si solo se muestra la opción de activación LBLM, significa que Tableau se configuró para utilizar LBLM como el único método de activación.  Los pasos a continuación actualizarán esta configuración para incluir ambos métodos de activación (claves de producto e inicio de sesión en el servidor):

1. Cierre todas las instancias de Tableau Desktop en ejecución.

2. Como administrador en el equipo donde se ejecuta Tableau Desktop, edite el Registro, y en HKEY_LOCAL_MACHINE\SOFTWARE\Tableau, busque el grupo llamado ATR y modifique el valor de LBLM de required a enabled.

3. Si utiliza un sistema operativo Mac, edite el archivo plist de la siguiente manera: sudo defaults write /Library/Preferences/com.tableau.ATR LBLM "enabled"

Edite el Registro para cambiar la configuración de administración de licencias basada en el inicio de sesión en Tableau Desktop.

Nota: Al configurarlo como "enabled", las pantallas de licencia mostrarán las dos opciones de activación (clave de producto o credenciales).

4. Reinicie Tableau Desktop y los usuarios deberían ver las dos opciones de activación: Activar con una clave de producto y Activar iniciando sesión en un servidor.

Causa

En el Registro de Windows o en un archivo plist de macOS, el valor LBLM está establecido en 'required'.  Cuando aparece la pantalla de licencia, ofrecerá solo la opción de credenciales para la activación.  Que LBLM sea el único método de activación puede ocurrir cuando las opciones de instalación predeterminadas se modificaron, ya sea a través de la línea de comandos o mediante la actualización del Registro de Windows o del archivo plist de Mac.

 
¿Fue de ayuda este artículo para resolver el problema?