KNOWLEDGE BASE

Fehler "Could not start Hyper: Failed to start a new Hyper instance" (Hyper konnte nicht gestartet werden: Starten eine neuen Hyper-Instanz fehlgeschlagen.) beim Öffnen von Tableau Workbooks


Veröffentlicht: 07 Oct 2021
Zuletzt geändert am: 06 Mar 2024

Problem

Beim Öffnen von Tableau-Arbeitsmappen in Tableau Desktop kann der folgende Fehler auftreten:

Could not start Hyper: Failed to start a new Hyper instance. Context: 0x86a93465 Caused by: The Hyper server process exited during startup with exit code: 1 (Hyper konnte nicht gestartet werden: Eine neue Hyper-Instanz konnte nicht gestartet werden. Kontext: 0x86a93465 Verursacht durch: Der Hyper-Server-Prozess wurde während des Starts mit Exit-Code 1 beendet. <...>
stderr: Unable to open log file (Protokolldatei konnte nicht geöffnet werden): CreateFileW<...>
The tag present in the reparse point buffer is invalid FileListener in error state after initial rotate() Context: 0x13cead20 (Das Tag im Reparse-Point-Puffer ist ungültig. FileListener im Fehlerzustand nach erstem rotate(). Kontext: 0x13cead20)
Unable to connect to the Tableau Data Extract server ". Check that the server is running and that you have access privileges to the requested database. (Verbindung zum Datenextrakt-Server " kann nicht hergestellt werden. Prüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsberechtigungen für die angeforderte Datenbank besitzen.)   

oder 

An error occurred while communicating with Tableau Data Extract. (Bei der Kommunikation mit dem Tableau-Datenextrakt ist ein Fehler aufgetreten.)
Bad Connection: Tableau could not connect to the data source. (Ungültige Verbindung: Tableau konnte keine Verbindung zur Datenquelle herstellen.)
Error Code (Fehlercode): AC0843EA
Could not start Hyper: Failed to start a new Hyper instance. (Hyper konnte nicht gestartet werden: Eine neue Hyper-Instanz konnte nicht gestartet werden.)
Context: 0x86a93465

Umgebung

  • Tableau Desktop
  • OneDrive

Lösung

Dieses Problem kann sowohl unter Windows als auch unter Mac auftreten, wenn OneDrive verwendet wird und der Tableau-Repository-Ordner in den Synchronisierungsordnern mit OneDrive enthalten ist. Dadurch wird Tableau daran gehindert, die Hyperprotokolle zu schreiben, was zu diesem Fehler führt. 

Verwenden Sie eine der folgenden Optionen:

Option 1

  1. Erstellen Sie einen neuen Ordner, der nicht mit OneDrive synchronisiert ist.
  2. Wählen Sie in Tableau Desktop "Datei > Repository-Speicherort" aus.
  3. Wählen Sie im Dialogfeld "Repository auswählen" einen neuen Ordner aus, der als neuer Speicherort für das Repository dienen soll.
  4. Starten Sie Tableau Desktop neu, damit es das neue Repository verwendet. 

Option 2

Heben Sie die Auswahl des Tableau Desktop Repository-Ordners (der Standardspeicherort ist Dokumente/Eigenes Tableau-Repository) in der OneDrive-App für die Synchronisierung auf. Weitere Informationen dazu finden Sie unter Auswählen, welche OneDrive-Ordner mit Ihrem Computer synchronisiert werden.

Option 3

Dieser Fehler kann auch im Zusammenhang mit dem Typ der verwendeten CPU auftreten. Weitere Einzelheiten finden Sie im nachstehenden Artikel. 

Fehler "Could Not Start Hyper: Failed To Start A New Hyper Instance" (Hyper konnte nicht gestartet werden: Starten einer neuen Hyper-Instanz fehlgeschlagen.) nach der Installation von Tableau 2020.4 oder neuer

Ursache

Die OneDrive-Synchronisierung verhindert, dass Tableau hyperd-Protokolle schreiben kann.
Hat dieser Artikel das Problem gelöst?