KNOWLEDGE BASE

Errore "The custom geocoding folder ... has errors" durante la creazione della mappa


Pubblicato: 27 Jan 2015
Data dell'ultima modifica: 11 Oct 2022

Problema

Durante la creazione di una mappa in Tableau Desktop, potrebbero verificarsi i seguenti errori:
 
The custom geocoding folder C:\Program Files (x86)\Tableau\Tableau 8.3\local\data has errors. (La cartella della geocodifica personalizzata C:\Program Files (x86)\Tableau\Tableau 8.3\local\data presenta degli errori.)
There was a problem connecting to the data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\AreaCode.tds: (Si è verificato un problema durante la connessione all'origine dati C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\AreaCode.tds:)
Error encountered while loading C:\Program Files (x86)\Tableau\Tableau 8.3\bin\fbclient.dll (Errore durante il caricamento di C:\Program Files (x86)\Tableau\Tableau 8.3\bin\fbclient.dll)
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it. (Impossibile connettersi al file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Verificare che il file esista e di disporre dei privilegi sufficienti ad accedere).

The custom geocoding data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\City.tds contains errors: (L'origine dati della geocodifica personalizzata C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\City.tds contiene degli errori:)
boost::bad_any_cast: failed conversion using boost::any_cast (boost::bad_any_cast: conversione con boost::any_cast non riuscita)
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it. (Impossibile connettersi al file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Verificare che il file esista e di disporre dei privilegi sufficienti ad accedere).

Ambiente

Tableau Desktop

Soluzione

Opzione 1

Verifica la presenza di una cartella firebird nella directory ProgramData:
  
 
1. Vai a: C:\ProgramData.
2. Verifica l'esistenza della cartella /firebird.
  • Verifica che le relative autorizzazioni siano impostate su "lettura/scrittura".
3. Se questa cartella non esiste:
  •      Crea una cartella denominata "firebird".
  •      Verifica che le relative autorizzazioni siano impostate su "lettura/scrittura".
 4. Riavvia Tableau Desktop e apri nuovamente la cartella di lavoro.

Se il mapping ancora non funziona dopo aver seguito la procedura indicata, disinstalla Tableau Desktop e installalo nuovamente:
  1. Procedi alla disinstallazione completa di Tableau Desktop.
    • Disinstalla l'applicazione.
    • Elimina la cartella di Tableau in: C:\Program Files o C:\Program Files (x86).
  2. Riavvia il computer.
  3. Reinstalla Tableau Desktop.

Opzione 2

  1. Vai a Pannello di controllo > Programmi e funzionalità e seleziona Tableau Desktop, quindi fai clic su Disinstalla/cambia
  2. Scegli Ripara l'applicazione dell'installazione.

Causa

Durante il processo di installazione Firebird non è stato installato correttamente. Come risultato, viene impostata una variabile FIREBIRD_LOCK che impedisce il funzionamento corretto della geocodifica. 
Con questo articolo hai risolto il problema?