BASE DE CONOCIMIENTO

Error "La carpeta de geocodificación personalizada... tiene errores" al crear un mapa


Publicado: 27 Jan 2015
Fecha de la última modificación: 11 Oct 2022

Problema

Al crear un mapa en Tableau Desktop, se pueden producir los siguientes errores:
 
The custom geocoding folder C:\Program Files (x86)\Tableau\Tableau 8.3\local\data has errors (La carpeta de geocodificación personalizada C:\Program Files (x86)\Tableau\Tableau 8.3\local\data tiene errores). 
There was a problem connecting to the data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\AreaCode.tds (Ha habido un problema al conectarse con la fuente de datos C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\AreaCode.tds): 
Error encountered while loading C:\Program Files (x86)\Tableau\Tableau 8.3\bin\fbclient.dll (Se ha producido un error al cargar C:\Program Files (x86)\Tableau\Tableau 8.3\bin\fbclient.dll). 
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it (No se ha podido conectar con el archivo "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Compruebe que el archivo existe y que tiene suficientes privilegios de acceso).

The custom geocoding data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\City.tds contains errors (La fuente de datos de geocodificación personalizada C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\City.tds contiene errores): 
boost::bad_any_cast: failed conversion using boost::any_cast (boost::bad_any_cast: no se ha podido realizar la conversión mediante boost::any_cast).
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it (No se ha podido conectar con el archivo "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Compruebe que el archivo existe y que tiene suficientes privilegios de acceso).

Entorno

Tableau Desktop

Solución

Opción 1

Confirme que la carpeta firebird se encuentra en el directorio ProgramData:
 
 
1. Vaya a: C:\ProgramData.
2. Verifique que la carpeta /firebird existe.
  • Confirme que tiene los permisos definidos en "lectura/escritura".
3. Si esta carpeta no existe:
  •      Cree una carpeta llamada "firebird".
  •      Confirme que tiene los permisos definidos en "lectura/escritura".
 4. Reinicie Tableau Desktop y vuelva a abrir el libro de trabajo.

Si el mapeo todavía no funciona tras completar los pasos anteriores, desinstale Tableau Desktop y vuelva a instalarlo:
  1. Desinstale completamente Tableau Desktop.
    • Desinstale la aplicación.
    • Elimine la carpeta Tableau que se encuentra aquí: C:\Program Files o C:\Program Files (x86).
  2. Reinicie el equipo.
  3. Reinstale Tableau Desktop.

Opción 2

  1. Vaya a Panel de control > Programas y características, seleccione Tableau Desktop y haga clic en Desinstalar o cambiar.
  2. Elija Reparar la aplicación de instalación.

Causa

Durante el proceso de instalación, Firebird no se instaló correctamente. En consecuencia, se ha definido una variable FIREBIRD_LOCK, lo que impide que la geocodificación funcione correctamente.
¿Fue de ayuda este artículo para resolver el problema?