BASE DE CONOCIMIENTO

El dashboard está en blanco o le falta contenido tras publicar en Tableau Server o Tableau Cloud mediante diseños de dispositivo


Publicado: 30 Jul 2013
Fecha de la última modificación: 19 Jun 2023

Problema

Una vez que un libro de trabajo que contiene diseños del dispositivo se publica en Tableau Server o Tableau Cloud, el dashboard o la vista aparecen en blanco o de una forma distinta a como aparecen en Tableau Desktop.

Entorno

  • Tableau Server
  • Tableau Cloud

Solución

  1. Abra el libro de trabajo en Tableau Desktop.
  2. Compruebe si hay diseños alternativos (para tableta, teléfono móvil o escritorio) además del diseño predeterminado.
  3. Haga clic en todos los diseños para ver si hay alguno distinto al diseño predeterminado.
  4. Elimine o actualice el diseño (para tableta, teléfono móvil o escritorio) que sea diferente del de la vista predeterminada, para que coincidan.
  5. Vuelva a publicar el libro de trabajo sobrescribiendo el anterior para actualizarlo y solucionar el problema.
HAGA CLIC PARA ABRIR UN EJEMPLO

Causa

Se pueden agregar diseños alternativos por error, o variaciones respecto al diseño "predeterminado" de Tableau Desktop. Si esto ocurre, y ve el libro de trabajo publicado en el dispositivo con ese diseño en concreto, el libro de trabajo tendrá un aspecto diferente al de Tableau Desktop cuando lo vea en Tableau Server o Tableau Cloud. Esto solo ocurre si el contenido real es distinto al diseño cuando se compara con el diseño de vistas predeterminado de contenido (por ejemplo, algunas vistas aparecen en blanco o no aparecen).
 

Información adicional

Nota: Este artículo solo abarca el problema de dashboard en blanco debido a un diseño alternativo. Hay muchos motivos por los cuales un dashboard o una vista pueden aparecer en blanco.  
La vista en blanco después de hacer una publicación también puede ocurrir cuando el libro de trabajo se publica desde una versión más reciente de Tableau Desktop a una versión más antigua de Tableau Server. Si las funcionalidades de la versión más reciente de Tableau Desktop no existen en una versión anterior de Tableau Server, la vista no se mostrará.
Opción 1: exporte el libro de trabajo a una versión compatible de Tableau Desktop y publíquelo desde esta instancia admitida.
Opción 2: actualice Tableau Server a una versión más reciente que sea compatible con Tableau Desktop.

Pueden aplicarse otros casos:

La vista aparece en blanco después de publicar una vista con un filtro en el que se utiliza la función "username"
El objeto de página web vinculado a una URL basada en la Web se queda en blanco tras la publicación
El objeto de página web vinculado a un archivo local se queda en blanco tras la publicación
Las hojas del dashboard aparecen en blanco al usar filtros rápidos
 
¿Fue de ayuda este artículo para resolver el problema?