KNOWLEDGE BASE

Unable to Join Salesforce Tables


Published: 22 May 2013
Last modified date: 20 Jul 2023

Issue

When you try to connect to Salesforce using the Multiple Tables option, not all tables appear in the Add Table dialog box.

Additionally, some table joins that work in one direction do not work in the other direction. For example, you can join Table A to Table B, but not Table B to Table A.

Environment

Tableau Desktop

Resolution

Try the following steps:

  • If you are using custom objects, make sure that the first table in the join contains a Reference field that points to the second table.

    For example, make sure Table A has a field of type Reference('B').

  • If you are using an inner join, try reversing the order.

    For example, instead of joining Table A to Table B, try joining Tableau B to Table A.

  • If you are using a left join, or if neither of the previous steps were successful, use data blending instead.

Cause

Table ("Object" in Salesforce terminology) relationships are predefined in Salesforce. To join two tables, the first table must contain a Reference field that points to the second table. The two tables must have an established primary key/foreign key relationship. The foreign key is the Reference field of the first table, and the primary key is the ID field of the second table.

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