BASE DE CONOCIMIENTO

Error "No license found for 'TableauServer'" (No se ha encontrado ninguna licencia para "TableauServer")


Publicado: 26 Feb 2013
Fecha de la última modificación: 20 Jul 2023

Problema

Cuando intente activar una clave de licencia de Tableau Server, es posible que vea el error siguiente:

No license found for 'TableauServer' (Sin licencia para "TableauServer")

Además, no aparece ninguna clave en la página Administrar claves de productos.

Entorno

  • Tableau Server 2018.1.x y versiones anteriores
  • Tabadmin (pre-TSM)

Solución

Opción 1

Configure excepciones en el firewall para los procesos siguientes:
  • tableau.exe
  • lmgrd.exe

Opción 2

  1. Deshabilite el firewall local del equipo.
  2. Desactive el antivirus. Si no lo puede desactivar, excluya la carpeta de Tableau del antivirus.
  3. Abra C:\Windows\System32\drivers\etc\hosts y elimine o comente todas las líneas que contengan:127.0.0.1localhost o el nombre de host del equipo.
  4. Reinicie el servicio de licencias FlexNet y el servicio Administrador de licencias (tablicsrv) de Tableau Server. Para obtener más información, consulte Reiniciar un servicio en Microsoft TechNet.
  5. Confirme que el servicio de inicio de sesión secundario se haya iniciado y se seguirá iniciando automáticamente al iniciar el equipo:
    1. Siga los pasos descritos en Verificar la configuración de Tableau.
    2. Haga clic con el botón derecho en el nombre del servicio y, a continuación, seleccione Iniciar.
    3. Haga clic con el botón derecho en el nombre del servicio y, a continuación, seleccione Propiedades. Establezca Tipo de inicio en Automático.
  6. Intente conectarse a Tableau Server de nuevo.
  7. Vuelva a habilitar el firewall local.

     

      Causa

      El servicio tablicsrv local no se puede conectar al servicio de licencias FlexNet de Tableau Server.

      Información adicional

      Si las soluciones anteriores no resuelven el problema, pruebe las opciones siguientes de solución de problemas:

      • Compruebe si un firewall está bloqueando el tráfico de red hacia el servidor de licencias. Los antivirus como McAfee suelen habilitar su propio firewall.
      • Compruebe si el puerto 27000 está disponible.
      • Compruebe que la fecha y la hora del sistema sean correctas.
      • Asegúrese de ejecutar Administrar claves de productos como administrador.
      • Si está conectado a una VPN, deshabilítela antes de activar la clave de licencia.La VPN se puede habilitar después de activar la licencia.
      • Ambos servicios deben estar configurados para que se ejecuten como Cuenta del sistema.
      • Aunque el mensaje de error aparece durante la activación, se crea un registro en un almacén de confianza. Después de reiniciar los servicios, aparece una clave automáticamente en la página Administrar claves de productos.

      Si ninguna de las soluciones ni los pasos de solución de problemas lo resuelven, póngase en contacto con el equipo de soporte técnico de Tableau e indique los datos siguientes:

      Aquí tiene mensajes de error relacionados que puede que vea en los archivos de registro:

       
      MensajeArchivo de registroSignificado
      lc_checkout return value: -95 (internal code)tabsrvlic.log or wgserver_lic.logtablicsrv cannot connect to FLEXnet.
      Vendor daemon can't talk to lmgrd (License server machine is down or not responding. (-96,491)tablicsrv.logtablicsrv cannot connect to FLEXnet.
      -97 (internal code)tabsrvlic.logtablicsrv cannot be started (check Log On As settings in Services)


      ¿Fue de ayuda este artículo para resolver el problema?