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Errore "No Tableau Server user found" durante la connessione a un'origine dati o la visualizzazione di una dashboard


Pubblicato: 28 Jan 2013
Data dell'ultima modifica: 24 Aug 2022

Problema

Quando si tenta di accedere alle dashboard o di inviare messaggi e-mail di sottoscrizione in Tableau Server o Tableau Cloud, potrebbe verificarsi il seguente errore:

No server user found class DataSourceException Unable to connect to server <server name or IP address>. Check that the server is running and that access privileges to the requested database. (Nessun utente del server trovato - classe DataSourceException - Impossibile connettersi al server <nome server o indirizzo IP>. Verifica che il server sia in esecuzione e che disponga dei privilegi di accesso per il database richiesto.)

Quando si tenta di connettersi a un'origine dati pubblicata da Tableau Desktop, potrebbe verificarsi il seguente errore:
 
com.tableausoftware.controller.dataserver.SessionController - Error response. code:401 type:DataServerNoAuth msg:No Tableau Server user found. (com.tableausoftware.controller.dataserver.SessionController - Risposta di errore. codice: 401 tipo: DataServerNoAuth msg: Nessun utente di Tableau Server trovato.)

Ambiente

  • Tableau Server
  • Tableau Cloud
  • Tableau Desktop con origini dati pubblicate
  • Server di dati

Soluzione

Esistono due cause comuni per questo problema. Procedi come segue, a seconda della situazione. 

Causa 1: Autorizzazioni utente (Tableau Server e Tableau Cloud)

Se alcuni utenti e alcune cartelle di lavoro sono interessati, verifica che:
Gli utenti interessati dispongano dell'autorizzazione CONNECT per l'origine dati pubblicata. Vedi Funzionalità che è possibile impostare sulle origini dati.
O
Le cartelle di lavoro interessate dispongano di credenziali incorporate dal Publisher.

 

Causa 2: Proxy di inoltro (solo Tableau Server)

Se tutti gli utenti e tutte le cartelle di lavoro o le origini dati sono interessati ed è in uso un server proxy di inoltro, configura il proxy in modo che siano specificate le eccezioni indicate in Configurare Tableau Server per un proxy di inoltro. Tieni presente che questa configurazione deve essere eseguita nel computer principale e in tutti i computer worker in un ambiente distribuito.
 

Causa

Causa 1: L'utente non dispone dell'autorizzazione per accedere all'origine dati pubblicata.

Causa 2: Un proxy di inoltro interferisce con le comunicazioni di Data Server. Tutte le comunicazioni di Data Server avvengono tramite HTTP.

Ulteriori informazioni

Se il problema viene riscontrato nelle cartelle di lavoro con origini dati incorporate, verifica che l'utente Esegui come per Tableau Server disponga delle autorizzazioni corrette. Per maggiori informazioni sull'impostazione di tutte le autorizzazioni appropriate per l'utente Esegui come, consulta il seguente articolo della Guida di Tableau: Utente Esegui come.
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