BASE DE CONOCIMIENTO

Error "No Tableau Server user found" al conectarse a una fuente de datos o ver un dashboard


Publicado: 28 Jan 2013
Fecha de la última modificación: 24 Aug 2022

Problema

Cuando intente acceder a sus dashboards o enviar correos electrónicos de suscripción en Tableau Server o Tableau Cloud, es posible que se produzca el siguiente error:

No server user found class DataSourceException Unable to connect to server <server name or IP address> (No se ha encontrado ningún usuario del servidor de la clase DataSourceException No se ha podido conectar con el servidor <server name or IP address>. Compruebe que el servidor está ejecutándose y que los privilegios de accesos a la fuente de datos seleccionada son correctos.

Cuando intenta conectarse a una fuente de datos publicada de Tableau Desktop, es posible que se produzca el siguiente error:
 
com.tableausoftware.controller.dataserver.SessionController - Error response. code:401 type:DataServerNoAuth msg:No Tableau Server user found. (com.tableausoftware.controller.dataserver.SessionController - Error response. code:401 type:DataServerNoAuth msg: No se ha encontrado ningún usuario de Tableau Server).

Entorno

  • Tableau Server
  • Tableau Cloud
  • Uso de Tableau Desktop con fuentes de datos publicadas
  • Data Server

Solución

Hay dos causas comunes para este problema.Siga estos pasos si se aplican a su situación:

Causa 1: Permisos de usuario (Tableau Server y Tableau Cloud)

Si algunos usuarios y libros de trabajo se ven afectados, compruebe que:
Los usuarios afectados tienen el permiso de conexión a la fuente de datos publicada.Consulte Funcionalidades que se pueden establecer en las fuentes de datos.
O
Los libros de trabajo afectados tienen credenciales incrustadas por el publicador.

 

Causa 2: Proxy de reenvío (solo Tableau Server)

Si todos los usuarios y libros de trabajo o fuentes de datos se ven afectados y se está utilizando un servidor proxy de reenvío, configure el proxy para garantizar que se especifican las excepciones en Configurar para un servidor proxy de reenvío. Tenga en cuenta que esta configuración se debe llevar a cabo en la máquina principal y en todas las máquinas del trabajador de un entorno distribuido.
 

Causa

Causa 1: El usuario no tiene permiso para acceder a la fuente de datos publicada.

Causa 2: Un proxy de reenvío está provocando interferencias en las comunicaciones del servidor de datos.Todas las comunicaciones del servidor de datos se producen por HTTP.

Información adicional

Si los libros de trabajo con fuentes de datos incrustradas están experimentando este problema, compruebe que el usuario Ejecutar como para Tableau Server tiene los permisos adecuados. Para obtener más información sobre cómo establecer los permisos del usuario Ejecutar como correctos, consulte el siguiente artículo de las páginas de ayuda de Tableau: Usuario Ejecutar como.
¿Fue de ayuda este artículo para resolver el problema?