知识库
尝试使用“从源刷新”选项刷新已发布数据源时 出现错误“重新连接至…”
发布时间: 01 Mar 2017
上次修改日期: 11 Oct 2023
问题
在 Tableau Desktop 中使用从源刷新选项时(之前对相同的工作簿和数据源可以正常运行),数据不刷新,并出现类似下列的错误消息:
“重新连接到 [奇数字符串]?”
解决方案
- 从 Tableau Desktop 连接到数据源并刷新本地副本。
- 右键单击刷新失败的已发布数据源,并选择“创建本地副本”。
- 右键单击新创建的本地提取,转到“提取”并选择“刷新”。
- 检查是否刷新了提取。
- 注意: 如果提取的本地副本刷新失败,则问题存在于 Tableau Desktop 和数据库之间;而不在 Tableau Bridge(同步客户端)或 Tableau Cloud。
- 在 Tableau Desktop 中刷新本地副本后,请在 Tableau Cloud 中刷新数据源。
- 如果步骤 2 未能解决问题,请将数据源重新发布到 Tableau Cloud。
原因
在 Tableau Cloud 中重新建立到数据库的连接后,使用“从源刷新”选项可能可以在 Tableau Desktop 中再次正常运行。从源刷新命令仅对包含原始数据源连接的提取可以正常运行。