KNOWLEDGE BASE

Error "Reconnect To..." When Attempting to Refresh a Published Data Source Using Refresh from Source Option


Published: 01 Mar 2017
Last Modified Date: 20 Sep 2023

Issue

When using the Refresh from Source option in Tableau Desktop (which has worked for the same workbook and data source in the past), the data does not refresh and a error message similar to the following occurs:
 
"Reconnect to [odd string of characters]?" 

Environment

  • Tableau Cloud

Resolution

  1. Connect from Tableau Desktop to the data source and refresh the local copy.  
    • Right-click the published data source that failed to refresh and select "Create Local Copy". 
    • Right-click on the newly created local extract, go to "Extract" and select "Refresh". 
    • Check to see if the extract is refreshed.
    • Note: If the local copy of the extract fails to refresh, the issue exists between Tableau Desktop and the database; not with Tableau Bridge (Sync Client) or Tableau Cloud. 
  2. After the local copy was refreshed in Tableau Desktop, refresh the data source in Tableau Cloud.
  3. If steps 2 did not resolve the issue, then re-publish the data source to Tableau Cloud.

 

Cause

Once a connection is re-established in Tableau Cloud to the database, using the Refresh from Source option may work again in Tableau Desktop. The Refresh from Source command is functional only for extracts that include a connection to the original data source. 
 
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