知识库

计划数据提取刷新间歇性失败,没有错误消息


发布时间: 21 Oct 2016
上次修改日期: 20 Jul 2023

问题

如果将已发布的数据提取计划为全天频繁刷新,则某些数据提取的更新频率不会像预期的那样频繁。
此外,消息“[datasource name extract refresh] is already queued. Not queuing a duplicate”([数据源名称数据提取刷新] 已排队。未对重复项进行排队)在后台程序日志中出现多次

环境

Tableau Server

解决方案

以下选项之一可能会解决此问题:
选项 1
如果尽可能使数据保持最新很重要,请考虑与数据库建立实时连接,以防止持续的数据提取刷新。
选项 2
使用 Tableau Server 中的“数据提取后台任务”报告,确定比“刷新窗口”处理时间更长的数据提取。如果数据提取需要 20 分钟才能完成,则让其每 15 分钟刷新一次将导致后台程序被该单个数据提取刷新所独占。
选项 3
降低数据提取刷新的频率。如果所有数据提取都以 15 分钟为增量进行刷新,则将计划增加到 30 分钟
选项 4
重新配置 Tableau Server 进程以增加后台程序计数

注意:如果没有可用的系统资源,增加后台程序进程计数不会解决问题。


 

原因

后台程序超载,无法在可用时间内完成作业。

其他信息

  • 在后台程序日志文件夹中搜索短语“存储到存储库”以查找成功数据提取刷新的实例
  • 在后台程序日志文件夹中搜索短语“已排队。未对重复项进行排队”以查找已运行时触发的数据提取刷新的实例
  • 数据提取报告的后台任务中未显示错误消息。

此文章是否已解决问题?