KNOWLEDGE BASE

Zwischenzeitlicher Fehler der geplanten Extraktaktualisierung ohne Fehlermeldung


Veröffentlicht: 21 Oct 2016
Zuletzt geändert am: 20 Jul 2023

Problem

Wenn geplant ist, dass veröffentlichte Extrakte im Tagesablauf häufig aktualisiert werden sollen, werden einige Extrakte nicht so häufig wie erwartet aktualisiert.
Zusätzlich wird die Meldung "[datasource name extract refresh] is already queued. Not queuing a duplicate" ([Datenquellennamen-Extraktaktualisierung] ist bereits in der Warteschlange. Es wird keine Kopie in die Warteschlange eingereiht.) oft im Protokoll der Hintergrundprozesskomponente angezeigt.

Umgebung

Tableau Server 

Lösung

Eine der folgenden Optionen kann das Problem beheben:
Option 1
Es ist wichtig, Daten möglichst auf dem aktuellen Stand zu halten. Stellen Sie ggf. eine Direktverbindung mit der Datenbank her, um konstante Extraktaktualisierungen zu verhindern.
Option 2
Identifizieren Sie im Bericht "Hintergrundaufgaben für Extrakte" in Tableau Server Extrakte, deren Ausführung länger dauert als das Aktualisierungsfenster. Dauert die Fertigstellung eines Extrakts 20 Minuten, führt eine alle 15 Minuten vorgenommene Aktualisierung dazu, dass die Hintergrundprozesskomponente einzig von dieser einzelnen Extraktaktualisierung beansprucht wird.
Option 3
Verringern Sie die Häufigkeit von Extraktaktualisierungen. Werden die Extrakte allesamt in 15-minütigen Schritten aktualisiert, sollten Sie die Abstände auf 30 Minuten festlegen.
Option 4
Konfigurieren Sie Tableau Server-Prozesse neu, um die Hintergrundprozesskomponenten-Anzahl zu erhöhen.

Hinweis: Ohne verfügbare Systemressourcen wird das Problem durch das Erhöhen der Anzahl Prozesse der Hintergrundprozesskomponente nicht behoben.


 

Ursache

Die Hintergrundprozesskomponente ist übermäßig ausgelastet und kann die Aufträge nicht in der verfügbaren Zeit abschließen.

Zusätzliche Informationen

  • Suchen Sie im Ordner für das Protokoll der Hintergrundprozesskomponente nach dem Ausdruck "Storing to repository" (Wird im Repository gespeichert), um Instanzen erfolgreicher Extraktaktualisierungen zu finden.
  • Suchen Sie im Ordner für das Protokoll der Hintergrundprozesskomponente nach dem Ausdruck "bereits in der Warteschlange. Es wird keine Kopie in die Warteschlange eingereiht, um Instanzen von auszulösenden Extraktaktualisierungen zu finden, die bereits ausgeführt werden
  • Im Bericht "Hintergrundaufgaben für Extrakte" werden keine Fehlermeldungen angezeigt.

Hat dieser Artikel das Problem gelöst?