KNOWLEDGE BASE

Fehler "Arbeitsblatt ist nicht verfügbar. Beim Verbinden mit der Datenquelle <Datenquellenname> ist ein Problem aufgetreten." nach dem Öffnen einer Arbeitsmappe


Veröffentlicht: 27 Sep 2016
Zuletzt geändert am: 09 Dec 2022

Problem

Beim Öffnen einer Arbeitsmappe in Tableau Desktop mit einer veröffentlichten Datenquelle kann der folgende Fehler auftreten:
"Worksheet Unavailable, There was a problem connecting to the "[Data Source Name]" data source. (Arbeitsblatt nicht verfügbar. Beim Verbinden mit der Datenquelle "<Datenquellenname>" ist ein Problem aufgetreten.)
 

Umgebung

  • Tableau Desktop
  • Tableau Server
  • Proxy und Firewall

Lösung

  1. Wenn sich Tableau Server hinter einem Proxy befindet, stellen Sie sicher, dass der "gateway.public.host name" korrekt eingestellt ist. Weitere Informationen finden Sie unter Konfigurieren von Proxies für Tableau Server
  2. Wenn die oben genannten Informationen korrekt sind und das Problem weiterhin besteht, versuchen Sie Folgendes:
    • Veröffentlichen Sie die Datenquelle erneut.
    • Klicken Sie bei gedrückter rechter Maustaste auf Datenquellen > Tableau-Datenserver > Server- und Websitepfad bearbeiten. > Geben Sie den erwarteten Tableau Server-Site-Namen ein.
    • Wenn viele Datenquellen von diesem Problem betroffen sind, kann die Verwendung der REST-API zum Schreiben von Skripten die Automatisierung des oben genannten Prozesses ermöglichen. Weitere Informationen finden Sie unter Aktualisieren der Datenquellenverbindung

      Das Entwicklerportal in der Community ist die beste Ressource zur Unterstützung beim Schreiben von REST-API-Skripten.

Ursache

Dieser Fehler hat möglicherweise folgende Ursachen: 
  1. Der "gateway.public. host name" wurde beim Upgrade von Tableau Server nicht aktualisiert. 
  2. Es ist bekannt, dass Proxies Probleme verursachen, wenn eine Tableau Server-Adresse auf localhost oder den Tableau Server-Computernamen zurückverweist, statt auf den Namen der Website.
Hat dieser Artikel das Problem gelöst?