KNOWLEDGE BASE

Error "Data Extract Required" Saving Workbook to Tableau Public


Published: 23 Feb 2016
Last modified date: 27 Jul 2023

Issue

When working in the Tableau Public Desktop client software, the following error can occur after signing in to the Tableau Public Server:
 
Data Extract Required
The Tableau server you are publishing to does not permit external database connections. Use the Data menu to create an extract for the following data source:
<data-source-name>

User-added image

Environment

  • Tableau Public Server
  • Tableau Desktop
  • Active data connection 

Resolution

The error screenshot explains that it is possible to create an extract using the Data menu but that is not available in the Tableau Public Desktop. The error screenshot has invalid information not applicable to the Public Desktop version. It is not possible to force extract creation in the Tableau Public Desktop. This error can occur when working with a live data source in Tableau Public after just signing in to the Tableau Public Server.  To resolve the issue perform the following:

1. Close the error window and complete updates to the workbook.  
2. Publish the workbook to the Tableau Public Server where the publish function will create the extract. Select File > Save to Tableau Public or Save to Tableau Public As.

 For a workbook that uses a live connection to a supported data source, when publishing the workbook to the Tableau Public Server, Tableau Public Desktop will create the extract by default.

User-added image

After publishing the workbook to the Tableau Public Server, the data shows as an extract in the workbook:

User-added image

Please Note: If you have received a workbook from another source and opened the workbook in the Tableau Public Desktop but then received an error trying to publish, it will be necessary to contact the workbook owner to extract the data.  It is not possible to create an extract in the Tableau Public Desktop from a the main toolbar or the Data pane window.
 

 

Cause

The Tableau Desktop Public Edition and Tableau Public (web) work with data from Microsoft Excel, multiple text file formats, statistical files, Google Sheets and web data connectors.  It is not possible to save a workbook locally or create an extract manually using Tableau Public Desktop by design.

The error can occur by just signing in to the Tableau Public Server when the data source is live because the Tableau Public Desktop recognises the data is not extracted.  

Additional information

The Tableau Desktop Public Edition does not usually display this error message because Tableau Desktop Public automatically saves an extract of the data source when publishing the workbook to the Tableau Public server (web).  

For more information on Tableau Public including how Google Sheets data is refreshed, see the Tableau Public FAQ.

Tableau Community Discussion on an error trying to connect to the Tableau Public Server.

Is Tableau Public available or is there an overall operational issue?  Check the Tableau Trust site.
Did this article resolve the issue?