KNOWLEDGE BASE

Errore "User <username> could not be deleted because they own content." durante il tentativo di eliminare un utente


Pubblicato: 11 Feb 2016
Data dell'ultima modifica: 06 Mar 2024

Problema

Durante il tentativo di eliminare un utente, potrebbe comparire il seguente messaggio di errore, anche se apparentemente l'utente non è proprietario di alcuna cartella di lavoro, vista, origine dati e così via:
User <username> could not be deleted because they own content. <username> has been unlicensed. (Impossibile eliminare l'utente <nome utente> poiché è in possesso di contenuti. La licenza di <nome utente> è stata rimossa.)

Ambiente

  • Tableau Server 
  • Tableau Cloud

Soluzione

Passaggio 1 - Trova il contenuto di proprietà dell'utente
  1. Vai alla pagina Utenti del proprietario (cerca il nome del proprietario in Utenti e selezionalo).
  2. Tutti i contenuti di proprietà dell'utente, inclusi i progetti, verranno visualizzati in schede separate. 
  3. Trasferisci i contenuti a un altro utente.
Nota:
Assicurati di abilitare la creazione delle lenti e delle raccolte Chiedilo ai dati nella pagina Impostazioni sito perché, se sono disabilitate, le schede corrispondenti sono nascoste e l'amministratore del sito non può controllare questi contenuti nell'interfaccia utente.

Passaggio 2 - Trova le sottoscrizioni

Un amministratore Tableau Server può passare ad Attività > Sottoscrizioni. Potrebbe essere presente una sottoscrizione ancora associata all'utente.  Una ricerca in base all'utente potrebbe non consentire di trovare la sottoscrizione associata all'utente.

Ordina in base alla colonna "Sottoscrizioni", quindi scorri fino all'utente.  L'utente potrebbe avere l'opzione "Sottoscritto da" ancora associata al proprio account. Prendi nota degli utenti che hanno le sottoscrizioni ed effettua nuovamente la sottoscrizione con il nuovo proprietario del contenuto.

Se un utente è sottoscritto a una vista e successivamente la sua licenza viene rimossa, la sua sottoscrizione rimane ma l'e-mail non viene inviata.  Per una base di utenti molto ampia, se l'utente senza licenza è l'unico utente che riceve una sottoscrizione, sarà importante eliminare la sottoscrizione di questo utente ai fini delle prestazioni di Server.  Tableau Server eseguirà il lavoro ma non invierà l'e-mail. 
 

Causa

È impossibile rimuovere un utente se un contenuto è di proprietà, inclusi i progetti, ma la licenza dell'utente verrà rimossa. Per maggiori informazioni, consulta la Guida di Tableau Cloud per rimuovere gli utenti dal server.

Per una sottoscrizione, se l'utente A effettua una sottoscrizione per l'utente B, questa sottoscrizione non sarà visibile nella pagina dei contenuti dell'utente A.  L'utente A non dispone dell'autorizzazione per vedere a cosa è sottoscritto un utente specifico.
Con questo articolo hai risolto il problema?