知識庫

Error "Unable to connect to the file "<file path>". Check that the file exists and that you have sufficient access privileges for it." Refreshing Extract


發佈時間 : 14 May 2015
上次修改日期 : 20 Oct 2022

問題

重新整理位於網路磁碟機上的 Excel 檔案的擷取時,擷取可能會失敗並且背景工作檢視中會出現以下錯誤:

com.tableausoftware.nativeapi.dll.DataSourceException: (com.tableausoftware.nativeapi.dll.DataSourceException:)Unable to connect to the file "<file path>".(無法連線到檔案 "<file path>"。)檢查檔案是否存在,以及您是否對其具有足夠的存取權限。

環境

  • Tableau Server
  • Excel

解決方法

  • 檢查以確保檔案仍位於預期位置。
  • 在 Tableau Desktop 中更新資料連線以將 UNC 路徑反射到 Excel 工作簿,而不是包含對應磁碟機代號的檔案路徑,然後重新發佈工作簿。
  • 確保 Tableau Server 執行身份使用者具有檔案儲存位置的存取權限。
若要測試 Tableau Server 執行身份使用者是否具有檔案位置的存取權限,請以「執行身份」使用者身份登入執行 Tableau Server 的電腦,然後使用 Windows 檔案總管視窗中的 UNC 路徑嘗試存取存儲檔案的資料夾。

 

原因

此檔案已移動或刪除,或者 Tableau Server 執行身份使用者無法存取存儲檔案的位置。這可能是因為用於連線資料來源的路徑是對應路徑。由於執行身份使用者帳戶無法存取已在另一個使用者的安全上下文中進行驗證的資源,因此無法使用對應的路徑。


 
這篇文章是否解決了問題?