知识库

刷新数据提取时出现“Unable to connect to the file "<file path>". Check that the file exists and that you have sufficient access privileges for it.”错误


发布时间: 14 May 2015
上次修改日期: 20 Oct 2022

问题

刷新位于网络驱动器上的 Excel 文件的数据提取时,数据提取可能会失败,并且“后台任务”视图中出现以下错误:

com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it.(com.tableausoftware.nativeapi.dll.DataSourceException: 无法连接到文件“<文件路径>”。请检查文件是否存在,并且您具有该文件的足够访问权限。)

环境

  • Tableau Server
  • Excel

解决方案

  • 检查以确保文件仍然在预期的位置中。
  • 在 Tableau Desktop 中更新数据连接以反映 Excel 工作簿的 UNC 路径(而不是包括映射驱动器符的文件路径),并重新发布工作簿。
  • 确保 Tableau Server 用户运行身份对文件的存储位置具有访问权限。
若要测试 Tableau Server 用户运行身份是否对该文件位置具有访问权限,请以“运行身份”用户身份登录到运行 Tableau Server 的计算机,并尝试在 Windows 文件资源管理器窗口中使用 UNC 路径访问文件的存储文件夹。

 

原因

文件已被转移或删除,或者 Tableau Server 运行用户身份没有文件存储位置的访问权限。这可能是因为用于连接到数据源的路径是映射路径。 由于用户运行身份帐户无法访问已在另一个用户的安全上下文中经过身份验证的资源,因此该帐户无法使用映射路径。


 
此文章是否已解决问题?