ナレッジベース

検索サーバーのインデックスを再構築してもプロジェクト、ワークブック、ビューの表示の問題が解決しない


発行: 16 Mar 2020
最終修正日: 03 Apr 2023

問題

tsm maintenance reindex-search command を実行した後もプロジェクト、ワークブック、ビューが Tableau Server UI に表示されない

検索インデックスを再構築しようとした後に、次のような行がログに出力される場合があります。

Tabadmincontroller のログ

INFO com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Progress update for job RebuildSearchIndex, id: 806, step: RunIndexingOnVizportal, status: Running, message key: job.rebuild_search_index.step.run_indexing_on_vizportal, message data: , (ジョブ RebuildSearchIndex の進行状況更新, id: 806, ステップ: RunIndexingOnVizportal, ステータス: Running, メッセージ キー: job.rebuild_search_index.step.run_indexing_on_vizportal, メッセージ データ: ,)
2020-03-12 20:02:42.494 -0500 pool-14-thread-1 : ERROR com.tableausoftware.tabadmin.webapp.init.RebuildSearchIndex - Failed to rebuild search index. Please check whether a valid Tableau Server license is present and check the vizportal logs. (検索インデックスの再構築に失敗しました。有効な Tableau Server ライセンスが存在するかどうかを確認し、vizportal のログも確認してください。)

VizPortal のログ
2020-03-12 20:02:42.492 -0500 (,,,,) VizportalMaintenanceServiceThread : ERROR com.tableausoftware.domain.solr.SearchService - Failed to gather solr stats (solr 統計を収集できませんでした)
com.tableausoftware.domain.exceptions.SearchServiceException: Error from server at https://localhost:8191/solr/view: Expected mime type application/octet-stream but got application/json. { (https://localhost:8191/solr/view のサーバーからのエラー: 期待されていた MIME の種類は application/octet-stream ですが、実際には application/json でした。)
"error":{
"metadata":[
"error-class","org.apache.solr.core.SolrCoreInitializationException",
"root-error-class","org.apache.lucene.index.CorruptIndexException"],
"msg":"SolrCore 'view' is not available due to init failure: Error opening new searcher", (初期化失敗により SolrCore 'view' が利用できません: 新しいサーチャーを開くときのエラー)
"trace":"org.apache.solr.core.SolrCoreInitializationException: SolrCore 'view' is not available due to init failure: Error opening new searcher\r\n\tat (初期化失敗により SolrCore 'view' が利用できません: 新しいサーチャーを開くときのエラー)

 

環境

  • Tableau Server

解決策

  1. Tableau Server が想定どおりにライセンスされていることを確認します。TSM の UI またはコマンド ラインにアクセスし、ライセンスが想定どおりに認証されていることを確認します。  ライセンスが想定どおりに認証されていない場合は、次の手順に進む前にライセンスを戻すか、またはテクニカル サポートに連絡してください。
  2. tsm stop を実行します。
  3. Tableau Server が完全に停止したら、バックアップを作成することをお勧めします。 ここで行う操作のためにシステムで問題が発生することは想定していませんが、常に、最新のバックアップの存在を確認することがベスト プラクティスになります。  
  4. tsm maintenance reset-searchserver を実行して、検索サーバーをリセットします。
  5. そのコマンドが完了したら、tsm start でもう一度サーバーを起動します。

    • 上記の手順で問題が解決しない場合は、Tableau テクニカル サポートに連絡してください。

    原因

    この問題は、参照元の searchserver インデックスの破損が原因で発生すると考えられます。これは、予期しない再起動中や、システムのアップグレード後などに発生する可能性があります。tsm maintenance reset-searchserver コマンドでは、古いインデックスを削除してインデックスを完全に再構築します。 
    この記事で問題は解決しましたか?