KNOWLEDGE BASE

Probleme mit dem Anzeigen von Projekten, Arbeitsmappen und/oder Ansichten konnten durch die Neuindizierung des Suchservers nicht behoben werden


Veröffentlicht: 16 Mar 2020
Zuletzt geändert am: 03 Apr 2023

Problem

Projekte, Arbeitsmappen und/oder Ansichten werden selbst nach dem Ausführen des Befehls tsm maintenance reindex-search nicht in der Tableau Server-Benutzeroberfläche angezeigt.

Nach dem Versuch, das Suchprotokoll neu zu indizieren, können Zeilen ähnlich der folgenden angezeigt werden:

tabadmincontroller-Protokolle

INFO com.tableausoftware.tabadmin.webapp.asyncjobs.JobStepRunner - Progress update for job RebuildSearchIndex, id: 806, step: RunIndexingOnVizportal, status: Running, message key: job.rebuild_search_index.step.run_indexing_on_vizportal, message data: ,
2020-03-12 20:02:42.494 -0500 pool-14-thread-1 : ERROR com.tableausoftware.tabadmin.webapp.init.RebuildSearchIndex - Failed to rebuild search index. Please check whether a valid Tableau Server license is present and check the vizportal logs. (Der Suchindex konnte nicht neu erstellt werden. Stellen Sie sicher, dass eine gültige Tableau Server-Lizenz vorhanden ist, und überprüfen Sie die VizPortal-Protokolle.)

VizPortal-Protokolle
2020-03-12 20:02:42.492 -0500 (,,,,) VizportalMaintenanceServiceThread : ERROR com.tableausoftware.domain.solr.SearchService - Failed to gather solr stats (Solr-Statistiken konnten nicht erfasst werden)
com.tableausoftware.domain.exceptions.SearchServiceException: Error from server at https://localhost:8191/solr/view: Expected mime type application/octet-stream but got application/json. { (Fehler vom Server unter https://localhost:8191/solr/view: Erwarteter Mime-Typ war application/octet-stream, aber empfangen wurde application/json. {)
"error":{
"metadata":[
"error-class","org.apache.solr.core.SolrCoreInitializationException",
"root-error-class","org.apache.lucene.index.CorruptIndexException"],
"msg":"SolrCore 'view' is not available due to init failure: Error opening new searcher", (SolrCore 'Ansicht' ist aufgrund eines Initialisierungsfehlers nicht verfügbar: Fehler beim Öffnen eines neuen Suchers)
"trace":"org.apache.solr.core.SolrCoreInitializationException: SolrCore 'view' is not available due to init failure: Error opening new searcher\r\n\tat (SolrCore 'Ansicht' ist aufgrund eines Initialisierungsfehlers nicht verfügbar: Fehler beim Öffnen eines neuen Suchers)

 

Umgebung

  • Tableau Server

Lösung

  1. Stellen Sie sicher, dass Tableau Server wie erwartet lizenziert ist. Rufen Sie TSM entweder über die Benutzeroberfläche oder die Befehlszeile auf und stellen Sie sicher, dass die Lizenzen wie erwartet aktiviert wurden.   Wenn die Lizenzen nicht wie erwartet aktiviert wurden, fügen Sie die Lizenzen wieder hinzu oder wenden Sie sich an den technischen Support, bevor Sie mit den nächsten Schritten fortfahren.
  2. Führen Sie tsm stop aus.
  3. Sobald Tableau Server vollständig beendet wurde, können Sie eine Sicherung erstellen. Wir erwarten zwar nicht, dass unsere Maßnahmen zu Problemen mit dem System führen, aber es ist immer ratsam, eine aktuelle Sicherung zu haben.  
  4. Setzen Sie den Suchserver zurück, indem Sie folgenden Befehl ausführen: tsm maintenance reset-searchserver.
  5. Nachdem dieser Befehl ausgeführt wurde, wird der Server mit dem Befehl tsm start wieder gestartet.

    • Wenn das Problem mit den obigen Schritten nicht behoben wird, wenden Sie sich an den technischen Support von Tableau.

    Ursache

    Dieses Problem scheint aufgrund einer Beschädigung des zugrundeliegenden Suchserver-Indexes aufzutreten. Es kann während eines unerwarteten Neustarts, nach Systemupgrades usw. auftreten. Mit dem Befehl tsm maintenance reset-searchserver wird der alte Index gelöscht und von Grund auf neu erstellt. 
    Hat dieser Artikel das Problem gelöst?