BASE DE CONNAISSANCES

Erreur « Échec du mode sans connexion [code d'état = 100000] » et « L'authentification Kerberos Exécuter en tant que n'est pas activée sur Linux » lors de l'actualisation des données sur le Cloud


Date de publication : 03 May 2019
Date de dernière modification : 19 Jun 2023

Problème

Lors de l'actualisation d'une source de données ou d'un classeur publié(e) à l'aide de Tableau Cloud, une erreur s'affiche, telle que : 

Connectionless Failure (status code = 10000) (Échec du mode sans connexion [code d'état = 10000])
There was an unknown connection error to the database (Erreur de connexion inconnue à la base de données).

Kerberos RunAs authentication is not enabled on Linux (L'authentification Kerberos Exécuter en tant que n'est pas activée sur Linux).
 

Environnement

  • Tableau Cloud
  • Source de données sur site

Résolution

  • Si vos données sont hébergées sur site ou dans le cloud privé, utilisez Tableau Bridge. Tableau Bridge est une application séparée gratuite que vous installez sur un ordinateur ayant accès à vos données. Bridge exécutera l'actualisation en local, puis distribuera le nouvel extrait jusqu'à Tableau Cloud.

Remarque : Tableau Bridge peut uniquement être utilisé avec des sources de données publiées ; il ne peut pas être utilisé avec des sources de données intégrées dans un classeur. Pour actualiser les sources de données à l'aide de Bridge, publiez de nouveau le classeur en publiant séparément les sources de données. Pour en savoir plus, consultez Configurer une programmation d'actualisation Bridge

Consultez la FAQ de Tableau Bridge pour trouver la réponse aux questions fréquemment posées sur Tableau Bridge.

  • Si vos données sont hébergées dans le cloud accessible publiquement, la solution comporte deux parties :

    1. Assurez-vous d'avoir bien ajouté à la liste autorisée les adresses IP Tableau Cloud concernées, comme indiqué dans Adresses IP Tableau Cloud autorisées pour le fournisseur de données. Tableau Cloud peut ainsi accéder à la base de données.
2. Lorsque vous vous connectez à la source de données et que vous la publiez, utilisez l'authentification par nom d'utilisateur/mot de passe, et non l'authentification Windows. Étant donné que Tableau Cloud n'a pas accès à votre réseau ou à Active Directory, il ne peut pas utiliser l'authentification Windows et doit utiliser un nom d'utilisateur/mot de passe à la place.

Cause

Tableau Cloud ne peut pas accéder à la source de données hébergée sur site ou utilisant l'authentification Windows.  Ce comportement se produit souvent si le calendrier d'actualisation d'extrait n'a pas été configuré correctement.
 
 
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