BASE DE CONNAISSANCES

Tableau Server sur Windows Server 2016 cesse de répondre ou n'a plus de licence


Date de publication : 18 Dec 2018
Date de dernière modification : 28 Dec 2023

Problème

Tableau Server sur Windows Server 2016 présente plusieurs problèmes, y compris : 

  • Les travaux planifiés sont lents ou échouent
  • Les performances de Tableau Server sont dégradées
  • Tableau Server se retrouve sans licence
  • Le rendu des visualisations est plus lent

En outre, ClusterController et/ou le Backgrounder peuvent contenir l'erreur suivante :
"Caused by: java.io.IOException: Unable to establish loopback connection" (Provoqué par : java.io.IOException : Impossible d'établir la connexion de bouclage)

Environnement

  • Tableau Server
  • Windows Server 2016
  • Pare-feu Windows
  • Connexions en direct à des sources de données

Résolution

Configurez Tableau Server Resource Manager (SRM) sur un intervalle d'interrogation moins fréquent - toutes les 10 secondes au lieu de 1 seconde par défaut. 
Remarque : cette solution nécessite de redémarrer Tableau Server. 

Pour Tableau Server 2018.2 et versions plus récentes :

Ouvrez une invite de commande en tant qu'administrateur sur le nœud sur lequel TSM est installé et entrez les commandes suivantes :

tsm configuration set -k native_api.check_interval_seconds -v 10 --force-keys
tsm pending-changes apply

 
 

Cause

Dans des cas de chargements spécifiques (chargement de classeurs avec de nombreuses connexions en direct, par exemple), plusieurs processus de publication et d'écoute de messages de diffusion Tableau Server Resource Manager (SRM) peuvent avoir lieu sur un seul nœud Tableau Server. Dans les versions futures de Tableau Server, des intervalles d'interrogation SRM moins fréquents seront configurés par défaut. Cette modification fait l'objet d'un suivi avec l'ID de problème 817676.  

Le défaut 817676 a été corrigé dans les versions de maintenance de mars 2019.
https://www.tableau.com/fr-fr/support/releases/server/2019.1.2
https://www.tableau.com/fr-fr/support/releases/server/2018.3.5
https://www.tableau.com/fr-fr/support/releases/server/2018.2.8
https://www.tableau.com/fr-fr/support/releases/server/2018.1.11
https://www.tableau.com/fr-fr/support/releases/server/10.5.14
https://www.tableau.com/fr-fr/support/releases/server/10.4.15
https://www.tableau.com/fr-fr/support/releases/server/10.3.19
 

Informations supplémentaires

Cette solution est actuellement recommandée pour toutes les installations Tableau Server s'exécutant sur Windows Server 2016. 
Pour vous assurer que le problème que vous rencontrez actuellement correspond à cet article, vérifiez ce qui suit.
Vérifiez que le service de pare-feu Windows est en cours d'exécution : 
  1. Cliquez sur Démarrer, puis saisissez « services.msc »
  2. Faites défiler jusqu'à « Pare-feu Windows »
  3. Vérifiez que l'état est « En cours d'exécution »
Recherchez « Unable to establish loopback connection » (Impossible d'établir la connexion de bouclage) dans les journaux de Tableau Server. 
Vérifiez que les journaux d'événements Windows ne contiennent pas les ID d'événements 4227 ou 4231. Ces ID d'événement pointent sur une insuffisance de ports temporaire. Si vous rencontrez des problèmes d'insuffisance de ports, consultez Problème d'insuffisance de ports dans Tableau Server.

 
Cet article vous a-t-il permis de résoudre le problème ?