KNOWLEDGE BASE

Workbook with Published Separately and Embedded Password Can Result in Error "Unable to connect to the data source"


Published: 31 Mar 2023
Last Modified Date: 08 Apr 2023

Issue

When publishing a workbook and data source simultaneously, and the Publish Type selected is "Published separately" and the Authentication selected is "Embedded password", some users may receive an error opening the published view.

User-added image
Some users may see the errors listed below when opening the published view:  
 
Unable to connect to the data source.
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner.
Or
DataServiceFailure
Unable to connect to the server "localhost". Check that the server is running and that you have the access privileges to the requested database.

 
Or
User(s) do not have permission to access datasource.
There was an error with the data source "[DataSourceName]". Verify that the data source is configured correctly.

 

Environment

  • Tableau Server
  • Tableau Cloud
  • Tableau Desktop

Resolution

To embed a password into a workbook, you should first publish the data source and then publish the workbook.

Once you have published the data source, you can embed the password into your workbook by selecting Embedded password in the publishing dialog.
User-added image

See the resolution in this article for more information.
 

Cause

Because the dialog doesn't have options for both the data source and the workbook to use the embedded credentials, the data source receives the embedded information.
 

Additional Information

If users lack connect permissions, an error may arise when attempting to open the view that utilizes the published data source.  In such a case, connect permissions are required for the data source when the workbook is set to Prompt Users. For further details, please refer to Data access for published Tableau data sources.
 
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