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When Running the Tableau Server Installer on Windows Server 2019+ It May Fail to Launch With "7-Zip Error can't create temp folder"


Published: 15 Mar 2022
Last Modified Date: 15 Mar 2022

Issue

When trying to run Tableau Server installer on Windows Server 2019, a cryptic error message appears:
 
"7-Zip Error can't create temp folder"

This occurs if the user has had a particularly long remote session (greater than 7 days) and had experienced disconnects. The problem is that the %TEMP% folder in the users profile is being removed and not re-created. The behavior of the temp directory being removed is considered by design by Microsoft.

Environment

Tableau Server, any version, running on Windows Server 2019/2022.

Resolution

The Microsoft link has a few workarounds to avoid the problem on a permanent basis. But the best workaround to get the installation completed would be to just log out and log back in so %TEMP% folder is recreated. If that doesn't work, then it's possible you are still on an old session and rebooting the server and re-connecting should resolve it.

Cause

When trying to run Tableau Server installer on Windows Server 2019, a cryptic error message appears:

"7-Zip Error can't create temp folder"
 
This occurs if the user has had a particularly long remote session (greater than 7 days) and has experienced disconnects. The problem is that the %TEMP% folder in the users profile is being removed by Cleanmgr.exe and not re-created. The behavior of the temp directory being removed is considered by design by Microsoft. See the link below for more information:

%TEMP% folder that includes the logon session ID is deleted unexpectedly

Additional Information

You will not see this behavior occurring, if the following is true: 
  • The %TEMP% folder isn't included in the logon session ID. For example, C:\Users\<User Account>\AppData\Local\Temp.  %TEMP% folder isn't empty.
  • Nobody logs on to the server.
  • Any user session that is ended within seven days.
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