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When dragging any field in the view after connecting to MSAS, getting error "Bad Connection: Tableau could not connect to the data source…Error Code: A7AED4D2…Unknown error communicating with data source (COM:0xC1010000)"


Published: 25 Aug 2020
Last Modified Date: 14 Jul 2021

Issue

After connecting to MSAS data source and upon dragging a dimension or measure to create a dashboard, the following error may occur:

Error Code A7AE04D2 - Unknown error communication with data source (COM 0xC1010000)",

Environment

  • Tableau Desktop 2020.1.0
  • Microsoft Azure SQL

Resolution

Option 1

Upgrade to Tableau Desktop 2020.3.3, 2020.2.8, 2020.1.11 or later.

Option 2

  1. Using the classic Programs and Features view in Control Panel.
  2. Uninstall any OLE DB drivers. See the below screenshot for reference.
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Driver: MSOLAP (amd64)
Version: 15.1.52.23
 
4. Open Tableau Desktop and reproduce the issue with dragging fields to the view.
   This will confirm that the driver and its components have been installed correctly.
 
5. Close all instances of Tableau Desktop.
6. Download the zip file called"140.zip" (attached).
 
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7. Open the following folder on the machine: C:\Program Files\Microsoft Analysis Services\AS OLEDB
8. Copy the folder from step 6 to this folder and select the "Replace the files in this destination" option.
 Click "Continue" on any administrative prompts.
9. Go into the "140" folder, right-click "msolap.dll" and select Properties.
10. On the Details tab, confirm that the product version is 15.0.19.24.
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Cause

This is a known issue that is fixed in more recent version of Tableau Desktop.
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