KNOWLEDGE BASE

When attempting to activate Tableau Desktop with ATR, the error "failed to obtain lease" is returned


Published: 30 Mar 2022
Last Modified Date: 01 Apr 2022

Issue

When activating Tableau Desktop, the error "failed to obtain lease" is returned.

Environment

  • Tableau Server 2020.1+
  • Tableau Server

Resolution

Option 1

Reinstall Tableau Server and enable ATR.

Option 2

Manually activate Tableau Desktop keys as a workaround:
Example:
"C:\Program Files\Tableau\Tableau <version>\bin\tableau.exe" -activate <product_key>"
 

Cause

Tableau Server was not installed with the ATR option selected.

Additional Information

ATRDiag on Tableau Server will have the following config key in the workgroup.yaml:

serverauthorizationtorun.enabled: false

If FALSE, ATR is disabled.

If TRUE, ATR is enabled.  

This can be verified by running the following command:
TSM configuration get -k serverauthorizationtorun.enabled

Selecting ATR for product activation is a permanent choice that cannot be easily undone. To change this later, Tableau Server needs to be backed up, uninstall, and then reinstalled.

Activate Tableau Server Using the Authorization-To-Run (ATR) Service
ATRDiag.exe Command Line Reference


 
Did this article resolve the issue?