KNOWLEDGE BASE

Web Data Connector Refresh of Extract on Tableau Server Leads to Infinite Loop and Fails


Published: 15 Jun 2018
Last Modified Date: 15 Jun 2018

Issue

In Tableau Server when a secondary WDC whitelist has been specified, refresh of an extract based on wdc data source will continously loop until timeout is reached and fails.

Additionally, the following error message cab be observed in the backgrounder log:

DataSourceException","is-bad-request":false,"is-local-configuration-error":false,"is-remote-configuration-error":false,"msg":"DataSourceException::Throw"}}
and
DataSourceException","msg":"Exception while executing command 'refresh-workbook-extracts'"}}
 

Environment

  • Tableau Server 10.5
  • Tableau Server 2018.1
  • Web Data Connector

Resolution

Work with your IT team to remove the secondary whitelist in the following way:
  1. tabadmin whitelist_webdataconnector -d "primary whitelist" "secondary whitelist"
    • For example: tabadmin whitelist_webdataconnector -d https://wdc1.example.com:443 https://wdc2.example.com
  2. tabadmin whitelist_webdataconnector -a "primary whitelist"
  3. tabadmin restart 
  4. Confirm only the primary whitelist is present with the command: tabadmin whitelist_webdataconnector -l 
  5. Perform a manual refresh again. The refresh should complete in a similar time as Tableau Desktop.

Cause

The secondary whitelist has been incorrectly specified
Did this article resolve the issue?