KNOWLEDGE BASE

"We are unable to verify your Tableau invitation" When Attempting to Activate Tableau Cloud Site


Published: 27 Jan 2023
Last Modified Date: 15 Feb 2023

Issue

When attempting to activate a Tableau Cloud Site via the activation email, an unexpected "We are unable to verify your Tableau invitation" error occurs.

Environment

  • Tableau Cloud

Resolution

As a workaround, try the following:
  • Check your email inbox (or spam and trash folder(s)) for a more recent site activation email
    • An automated site activation reminder email (containing a new activation link) is sent if your site hasn't been activated within 48 hours of receiving the initial site activation email
  • Clear your web browser's cache/cookies
  • Open a private browsing window (e.g. Google Chrome Incognito) and attempt the activation again
If additional assistance is required, please reach out to your Account Representative or customerservice@tableau.com.

Cause

An unexpected issue is occurring which could have various root causes.
Did this article resolve the issue?