KNOWLEDGE BASE

Vulnerabilities Present in Flexera Flexnet 11.16.1 And Earlier Versions


Published: 05 Sep 2019
Last Modified Date: 12 Nov 2019

Issue

Flexera Flexnet 11.16.1 and earlier versions are affected by several denial of service and remote code execution vulnerabilities. 

  • (CVE-2018-20031) A Denial of Service vulnerability related to preemptive item deletion in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a  combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down.
  • (CVE-2018-20032) A Denial of Service vulnerability related to message decoding in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd for the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down.
  • (CVE-2018.20033) A Remote Code Execution vulnerability in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier could allow a remote attacker to corrupt the memory by allocating / deallocating memory, loading lmgrd and the vendor daemon to stop. This would force the vendor daemon to shut down.
  • (CVE - 2018-20034)A Denial of Service vulnerability related to adding an item to a list on lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down.

Environment

Tableau Server

Cause

Flexera Flexnet 11.16.1 and earlier versions are affected by several denial of service and remote code execution vulnerabilities. 
Did this article resolve the issue?