KNOWLEDGE BASE

Views with User Filters are Blank and a Duplicated User "!External\username" can Occur after Changing User Auth Method


Published: 07 Oct 2022
Last Modified Date: 14 Oct 2022

Issue

When changing the authentication type for users, workbooks that utilize user filters will not display data for those users, and a duplicate user will show in the User Filter dialog in Tableau Desktop as "! external\username". 

Environment

  • Tableau Cloud
  • User Filters

Resolution

To address the issue, use one of the below options:

Option 1 Reconfigure the user filter for each user and republish the affected workbooks
  1. Download and open the workbook in Tableau Desktop.
  2. Right-click on the user filter and select Edit Set. 
  3. Look for the user from the list that does not show ! external\ and reconfigure the filter for that user. 
  4. Repeat the step 3 for all impacted users. 
  5. Select OK and republish the workbook.  
Note: Alternatively, you can recreate the filter rather than updating the existing broken one.

Option 2 Revert the authentication type for the affected users back to their original authentication method

Option 3 Use a dynamic row level security field from the data instead of the preset user filter function. See Create a User Filter and Secure it for Publishing for steps. 
Note: If you want to take this approach, the database must include the field you want to use for filtering the data.

Option 4 Purchase the Data Management Add-On, and use Virtual Connections with Data Policy to apply row level security. See About Virtual Connections and Data Policies for more information.

Cause

User filters do not support authentication changes.
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