KNOWLEDGE BASE

Upgrade to Tableau Server 2018.2 stuck at 92%


Published: 15 Aug 2018
Last Modified Date: 08 Oct 2018

Issue

When upgrading a Tableau Server trial to 2018.2, the process hangs at "Enabling the services required for indexing."  This generally happens 92% of the way through the installation.

Environment

  • Tableau Server 2018.2
  • Windows Server 2012

Resolution

Use the following workaround:

Step 1

If the script is blocked at starting or restarting services, perform the following task manually:

  1. Open the services by going to Start > Run > type in: services.msc.
  2. Click OK.
  3. Find Tableau Server Service Manager in the list of services.
  4. Right click on Tableau Server Service Manager and select Restart.
  5. Wait at least 5 minutes and the script should complete.
  6. If script does not finish and/or is stuck at 92%, proceed to Step 2.

Step 2

  1. Open browser and navigate to https://localhost:8850.
  2. Login as a TSM administrator user.
  3. When you are prompted for a license key, input a license key or select the trial below.
  4. Follow the registration steps.
  5. Tableau should begin initializing.
  6. Wait at least 5 minutes and the script should complete.

Cause

This behavior can be triggered by one of the following scenarios:

Scenario 1:

The virtual machine (VM) where Tableau Server is activated is cloned prior to deactivating Tableau Server, causing licensing issues. The ideal way to upgrade in this scenario is:
  1. Delete the cloned VM (retaining the original)
  2. De-activate Tableau Server on the original VM
  3. Clone the original VM with Tableau Server deactivated
  4. Re-activate Tableau Server on the cloned VM
  5. Verify maintenance dates are correct by 
  6. Upgrade Tableau Server on the cloned VM

Scenario 2:

Upgrading a trial version of Tableau Server to Tableau Server 2018.2 will also cause licensing issues.The idea way to upgrade to Tableau Server 2018.2 from a trial version is:
  1. Ensure you have a complete and functional backup of Tableau Server. For information on how to take a backup, see Back up Tableau Server data
  2. Remove Tableau Server by executing the tableau-server-obliterate script. For more information, see Running the tableau-server-obliterate script.
  3. Perform a fresh installation of Tableau Server
  4. Restore the new installation from a backup file. For information on how to restore from a backup, see Restore from a backup
Scenario 3:

Upgrading with a license that does not have valid maintenance for Server 2018.2 will trigger this symptom.
  1. Gather a current Tableau Server license key from the Customer Portal
  2. Following the “Step 2” procedure above, enter this license
If this has already been attempted unsuccessfully or the installation has been reverted, this procedure will prevent future occurrences:
  1. Revert to a prior version of Tableau Server
  2. Refresh product keys with the procedure at https://onlinehelp.tableau.com/v2018.1/server/en-us/license_refresh.htm
  3. Verify that the “Maintenance Expires” date is current
  4. Repeat the upgrade procedure
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