KNOWLEDGE BASE

Unable to Union Multiple Spatial Files


Published: 15 Nov 2018
Last Modified Date: 18 Aug 2020

Issue

Unable to union multiple spatial files.

Environment

  • Tableau Desktop
  • Spatial files

Resolution

Upgrade to Tableau Desktop 2020.3. This feature is released in 2020.3. Below is a previous workaround.

As a possible workaround, extract the spatial file and append data from other spatial files to the extracted data source.
  1. Open the first spatial file by Tableau Desktop.
  2. Go to Sheet 1 and right-click the data source, then click Extract Data.
  3. Click Extract and save the hyper file to a desired folder.
  4. Click Data > New Data Source and open another spatial file
  5. Go to Sheet 1 and right-click the extracted data source > Extract > Append Data From Data Source.
  6. Select the other data source and click OK.
  7. Repeat Step 1 to 6 for all other spatial files.
  8. Click File > Save and save the workbook as a twb file to a desired folder.
  9. Click File > New to open another Tableau Desktop instance.
  10. Click Connect to Data and open the hyper file saved at step 3.
    As this result, all spatial files are stored in the hyper file.
Did this article resolve the issue?