KNOWLEDGE BASE

Unable to Switch Tableau Bridge to Service Mode on Computer Joined to Azure AD


Published: 02 Aug 2023
Last Modified Date: 02 Aug 2023

Issue

When trying to switch Tableau Bridge to service mode on a computer that is joined to Azure AD, the following dialog may appear:

To finish switching to Service mode, you must log on to Windows as a local administrator.

Additionally, after clicking 'OK' on the dialog, the following error may occur:

There was an unexpected problem so the Tableau Bridge client will restart now.

Environment

  • Tableau Bridge
  • Windows

Resolution

As a workaround, create a local administrator account and use this account to run Tableau Bridge as a service.

For instructions on how to create a local administrator account in Windows, see Create a local user or administrator account in Windows.

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Cause

An Azure AD user account cannot be used to run services in Windows.
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