KNOWLEDGE BASE

Unable to Start Tableau Bridge to Run Automatically in Service Mode on Windows


Published: 25 Oct 2019
Last Modified Date: 04 Nov 2019

Issue

After restarting the computer where Tableau Bridge has been installed, the Service mode cannot start up automatically and extract refresh failure will occur if there are any tasks registered in the schedule.
 

Environment

  • Tableau Online 
  • Tableau Bridge
  • Windows

Resolution

Work with your IT team to perform the steps below: 

Check if "Log on as a service" is assigned to run as user of Tableau Bridge worker service.
  • Open Local Security Policy of Windows.
  • Choose Local Policies > User Rights Assignment
  • Click Log on as a service and check if the run as user of Tableau Bridge worker has been added.
           If not, add the run as user of Tableau Bridge worker here.
           (Run as user of Tableau Bridge worker can be confirmed by opening "Services"  and selecting "Tableau Bridge worker".)

Refresh username and password information of "Tableau Bridge worker"
       1. Open Services menu of Windows, and choose Tableau Bridge worker service.
       2. Right click and select Properties > Log On
       3. Check Log on as account name. Refresh username and password and select Apply, OK.
       4. After restarting Tableau Bridge, the configuration will be applied.

Cause

To start Tableau Bridge as service mode automatically after restarting Windows OS, the run as user of "Tableau Bridge worker" service need the authority of "Log on as a service",
and the newest service account information should be saved to the "Tableau Bridge worker" service.

Additional Information

  • If an expired password was saved to Tableau Bridge worker service, the password will be required so Bridge will not run automatically.
  • The following logon will also be required if the run as user of "Tableau Bridge worker" service has not been given the authority of "Log on as a service".
If an expired password was saved to Tableau Bridge worker service, the password will be required so Bridge will not run automatically.
Did this article resolve the issue?