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升級後無法登入,且 SAML 出現「Invalid username or password」錯誤


發佈時間 : 24 Dec 2018
上次修改日期 : 24 Aug 2022

問題

啟用 SAM 後,前往 Tableau Server 頁面會出現這個訊息:

"Unable to Sign In - Invalid username or password".(無法登入 - 使用者名稱或密碼無效)

環境

  • Tableau Server 2018.3.1
  • SAML
  • 透過 Proxy 或負載平衡器卸載 SSL

解決方法

設定 proxy 或負載平衡器,以將 X-FORWARDED-PROTO 標題設為「https」。
否則,請在 Tableau Server 上設定外部 SSL,以及完整的通道 SSL。

原因

SAML 程式碼現在會檢查已確保 AuthNRequest 會前往預定的 SAML 端點。如果 SSL 卸載透過 proxy 啟用,SAML 使用的返回 URL 將會是 https://<url>,但除非設定了 X-FORWARDED-PROTO 標題,Tableau Server 將會預期 http://<url> 的端點,因為外部 SSL 在 Tableau Server 不會設定。
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