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Unable to Sign In" および "Invalid username or password" エラーがアップグレード後に SAML で発生する


発行: 24 Dec 2018
最終修正日: 24 Aug 2022

問題

SAML を有効にした後、Tableau Server ページに移動すると次のメッセージが表示されます。

"Unable to Sign In - Invalid username or password" ("サインインできません - ユーザー名またはパスワードが無効です")

環境

  • Tableau Server 2018.3.1
  • SAML
  • プロキシまたはロードバランサーを介した SSL オフロード

解決策

プロキシまたはロード バランサーを構成して、 X-FORWARDED-PROTO のヘッダーを "https" に設定します。
または、Tableau Server で外部 SSL を構成しても SSL を完全にパス スルーできます。

原因

SAML コードにより、AuthNRequest が期待どおりの SAML エンドポイントに送信されていること確認します。SSL オフロードがプロキシを経由して有効になっている場合は、SAML で使用されるリターン URL は <https://<url>> になりますが、X-FORWARDED-PROTO のヘッダーが構成されていなければ、外部SSL のエンドポイントが Tableau Server で構成されないため、Tableau Server はエンドポイントが <http://<url>> であると予想します。
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